aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ssh-cert-authority/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ssh-cert-authority/APKBUILD')
-rw-r--r--testing/ssh-cert-authority/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/testing/ssh-cert-authority/APKBUILD b/testing/ssh-cert-authority/APKBUILD
index 768f035d6dd..da07472cac2 100644
--- a/testing/ssh-cert-authority/APKBUILD
+++ b/testing/ssh-cert-authority/APKBUILD
@@ -3,15 +3,19 @@
# Maintainer:
pkgname=ssh-cert-authority
pkgver=2.0.0
-pkgrel=3
+pkgrel=18
pkgdesc="An implementation of an SSH certificate authority"
url="https://github.com/cloudtools/ssh-cert-authority"
arch="all"
license="BSD-2-Clause"
makedepends="go"
-options="net"
+options="net chmod-clean"
source="$pkgname-$pkgver.tar.gz::https://github.com/cloudtools/ssh-cert-authority/archive/$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
local pkg=github.com/cloudtools/ssh-cert-authority
@@ -34,11 +38,4 @@ package() {
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
}
-cleanup_srcdir() {
- if [ -d "$srcdir" ]; then
- find "$srcdir" -print0 | xargs -0 chmod +w
- fi
- default_cleanup_srcdir
-}
-
sha512sums="495b4ba72b848eeeb86869ffe312f37d4f49e6e281e840f5680e8f55cc2d29b33c771bc46ee2755d25d198e58e5dea0ce28a649321f4f979f59a1c22ed4d6f1c ssh-cert-authority-2.0.0.tar.gz"