aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ssh-cert-authority/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ssh-cert-authority/APKBUILD')
-rw-r--r--testing/ssh-cert-authority/APKBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/testing/ssh-cert-authority/APKBUILD b/testing/ssh-cert-authority/APKBUILD
index 0d1ed804dd0..da07472cac2 100644
--- a/testing/ssh-cert-authority/APKBUILD
+++ b/testing/ssh-cert-authority/APKBUILD
@@ -1,41 +1,41 @@
+# Contributor: Carlgo11 <carlgo11@carlgo11.com>
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer:
pkgname=ssh-cert-authority
-pkgver=1.7.1
-pkgrel=2
+pkgver=2.0.0
+pkgrel=18
pkgdesc="An implementation of an SSH certificate authority"
url="https://github.com/cloudtools/ssh-cert-authority"
arch="all"
license="BSD-2-Clause"
-depends=""
makedepends="go"
+options="net chmod-clean"
source="$pkgname-$pkgver.tar.gz::https://github.com/cloudtools/ssh-cert-authority/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- cd "$builddir"
local pkg=github.com/cloudtools/ssh-cert-authority
- GO111MODULE=on HOME="$srcdir" go build \
+
+ # Fix build on riscv64
+ HOME="$srcdir" go mod edit -replace \
+ golang.org/x/sys=golang.org/x/sys@v0.0.0-20210630005230-0f9fa26af87c
+ HOME="$srcdir" go mod download golang.org/x/sys
+
+ HOME="$srcdir" go build \
-ldflags "-X $pkg/version.Tag=$pkgver \
-X $pkg/version.BuildVersion=$pkgver" \
-o bin/$pkgname
}
check() {
- cd "$builddir"
go test ./...
}
package() {
- cd "$builddir"
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
}
-cleanup_srcdir() {
- if [ -d "$srcdir" ]; then
- find "$srcdir" -print0 | xargs -0 chmod +w
- fi
- default_cleanup_srcdir
-}
-
-sha512sums="028f0484299ef2b598a168467e576cb3ff326e6cb9acc8393b4df68a29f0fb7a017332e3da8d4afffa9f86518f0d5bac588c11abf1f94ae1391066bc65ca9aa8 ssh-cert-authority-1.7.1.tar.gz"
+sha512sums="495b4ba72b848eeeb86869ffe312f37d4f49e6e281e840f5680e8f55cc2d29b33c771bc46ee2755d25d198e58e5dea0ce28a649321f4f979f59a1c22ed4d6f1c ssh-cert-authority-2.0.0.tar.gz"