aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ssh-honeypot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ssh-honeypot/APKBUILD')
-rw-r--r--testing/ssh-honeypot/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/testing/ssh-honeypot/APKBUILD b/testing/ssh-honeypot/APKBUILD
index 934938b47a4..c3ba9ca5444 100644
--- a/testing/ssh-honeypot/APKBUILD
+++ b/testing/ssh-honeypot/APKBUILD
@@ -1,24 +1,23 @@
# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
-pkgname="ssh-honeypot"
-pkgver="0_git20190717"
-_commit=b7baa9a6963e723ee0779a6cef0447739870ace3
-pkgrel=0
+pkgname=ssh-honeypot
+pkgver=0.1.1
+pkgrel=1
pkgdesc="Fake sshd that logs ip addresses, usernames, and passwords."
url="https://github.com/droberson/ssh-honeypot"
arch="all"
license="MIT"
depends="openssh-keygen"
-makedepends="json-c0.12-dev libssh-dev"
+makedepends="json-c-dev libssh-dev"
options="!check" # no testsuite and daemon returns 1 even on help command
subpackages="$pkgname-openrc"
-source="$pkgname-$pkgver.zip::https://github.com/droberson/ssh-honeypot/archive/$_commit.zip
+source="https://github.com/droberson/ssh-honeypot/archive/refs/tags/ssh-honeypot-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd"
-builddir="$srcdir/$pkgname-$_commit"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
- make CC="gcc" CFLAGS="$CFLAGS -fPIC"
+ make CC="${CC:-cc}" CFLAGS="$CFLAGS $LDFLAGS -fPIC"
}
package() {
@@ -28,6 +27,8 @@ package() {
install -m 644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="67edfac31421bb8ecbbff08b9dcc3169372da59f4dd83a21149af666b98c42c3a924f8dd6a5091d5928a258915c1f6a7611dbef872432e793fc42e786fd30201 ssh-honeypot-0_git20190717.zip
+sha512sums="
+178ab3e71a1891f6002b6d6bdb7086ed6e777fad9fcbcd42d52c9dc723917c15ecdc182d5fea2ad943bcaa5fc3730ea34ec744c1f2e5a83f6859f3f2771cce39 ssh-honeypot-0.1.1.tar.gz
759a0756e082bc946deec156c164dd5b40876f2f3cd1f3f0c526f06b009f70110ddfbc7730e295765f6c9e088f123a45909c94fe048e7f864b4946ae5a98f157 ssh-honeypot.initd
-e93b93117afa5f5ad93bce12e5846718bb25d24ace47bbcee1bbb72af51b0cc9fc7558a5650e4778330e5ad22d1807183ebc93101e7e16dfc6f7e391ba4aca6d ssh-honeypot.confd"
+e93b93117afa5f5ad93bce12e5846718bb25d24ace47bbcee1bbb72af51b0cc9fc7558a5650e4778330e5ad22d1807183ebc93101e7e16dfc6f7e391ba4aca6d ssh-honeypot.confd
+"