aboutsummaryrefslogtreecommitdiffstats
path: root/testing/stardict
diff options
context:
space:
mode:
Diffstat (limited to 'testing/stardict')
-rw-r--r--testing/stardict/APKBUILD66
-rw-r--r--testing/stardict/gcc46.patch11
-rw-r--r--testing/stardict/glib2.patch36
3 files changed, 113 insertions, 0 deletions
diff --git a/testing/stardict/APKBUILD b/testing/stardict/APKBUILD
new file mode 100644
index 00000000000..3775a8a742f
--- /dev/null
+++ b/testing/stardict/APKBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Taner Tas <taner76@gmail.com>
+pkgname=stardict
+pkgver=3.0.6
+pkgrel=0
+pkgdesc="Cross-platform and international dictionary software"
+url="http://stardict-4.sourceforge.net/"
+arch="all"
+license="GPL"
+depends="gtk+2.0 libsigc++ zlib"
+makedepends="automake autoconf libtool gtk+2.0-dev libsigc++-dev libxml2-dev gnome-doc-utils
+ gnome-common enchant-dev espeak-dev zlib-dev mariadb-dev gconf-dev"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-help::noarch"
+source="http://downloads.sourceforge.net/project/stardict-4/${pkgver}/${pkgname}-${pkgver}.tar.bz2
+ gcc46.patch
+ glib2.patch"
+options="!check"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ ./autogen.sh
+ find dict/src/sigc++* -name \*.h -or -name \*.cc | xargs rm -f
+}
+
+build() {
+ cd "$builddir"
+ export CXXFLAGS="$CXXLAGS -std=gnu++11"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-gnome-support \
+ --disable-dictdotcn \
+ --disable-gucharmap \
+ --disable-scrollkeeper \
+ --disable-festival \
+ --disable-updateinfo \
+ --disable-gpe-support \
+ --disable-schemas-install
+ make
+}
+
+check(){
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+help() {
+ pkgdesc="Stardict help files"
+ mkdir -p ${subpkgdir}/usr/share/stardict
+ mv ${pkgdir}/usr/share/gnome ${subpkgdir}/usr/share/
+ mv ${pkgdir}/usr/share/omf ${subpkgdir}/usr/share/
+ mv ${pkgdir}/usr/share/stardict/help ${subpkgdir}/usr/share/stardict/
+}
+
+sha512sums="81d93324b6e8954af7c20ea6d2a3054bb564d786a21b1cb541c728da7a18a6e7ddb23e595055ccc77e6866bbb8c89fb4f17023e33664761dbe1ee8cd55768658 stardict-3.0.6.tar.bz2
+cc43b57cdf2e7fbd3e9c86acb4c8f9fef367d68f6f027e75774eec9cdf66b3fdd3b0bc58d373d076cb38671e09012ab69b8b7e81638a5be888af56372e65a838 gcc46.patch
+4132eee58ab5dfb30105fd2c1a113d143528f7e904ededbb8de203bbb244377aed2c152aae7f383936e74005c2f4afa6128674a245d2a8083b2757b1ca90dd24 glib2.patch"
diff --git a/testing/stardict/gcc46.patch b/testing/stardict/gcc46.patch
new file mode 100644
index 00000000000..944b9635c7c
--- /dev/null
+++ b/testing/stardict/gcc46.patch
@@ -0,0 +1,11 @@
+diff -aur old/dict/stardict-plugins/stardict-wordnet-plugin/utils.h new/dict/stardict-plugins/stardict-wordnet-plugin/utils.h
+--- old/dict/stardict-plugins/stardict-wordnet-plugin/utils.h 2011-07-18 06:58:58.519404744 -0700
++++ new/dict/stardict-plugins/stardict-wordnet-plugin/utils.h 2011-07-18 07:01:10.739734313 -0700
+@@ -26,6 +26,7 @@
+ #ifndef __TYPES_H__
+ #define __TYPES_H__
+
++#include <cstddef>
+ #include <math.h>
+
+ typedef float single;
diff --git a/testing/stardict/glib2.patch b/testing/stardict/glib2.patch
new file mode 100644
index 00000000000..bd0f6bac80e
--- /dev/null
+++ b/testing/stardict/glib2.patch
@@ -0,0 +1,36 @@
+diff -Naur old/dict/configure.ac new/dict/configure.ac
+--- old/dict/configure.ac 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/configure.ac 2012-07-12 22:31:52.875176842 +1000
+@@ -266,6 +266,9 @@
+ fi
+ AC_SUBST(WIKI_PARSEDATA_PLUGIN_DIR)
+
++GMODULE2_LIBS=`pkg-config --libs gmodule-2.0`
++AC_SUBST([GMODULE2_LIBS])
++
+ dnl ================================================================
+ dnl main program checks.
+ dnl ================================================================
+diff -Naur old/dict/src/Makefile.am new/dict/src/Makefile.am
+--- old/dict/src/Makefile.am 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/src/Makefile.am 2012-07-12 22:29:53.714870692 +1000
+@@ -33,7 +33,7 @@
+ stardict_DEPENDENCIES = lib/libstardict.la $(LOCAL_SIGCPP_LIBFILE)
+ stardict_LDFLAGS =
+ ## place libstardict.la before any system library, otherwise build with --as-needed linker option may fail
+-stardict_LDADD = lib/libstardict.la $(STARDICT_LIBS) $(LOCAL_SIGCPP_LIBFILE)
++stardict_LDADD = lib/libstardict.la $(STARDICT_LIBS) $(LOCAL_SIGCPP_LIBFILE) $(GMODULE2_LIBS)
+
+ if !GNOME_SUPPORT
+ if MAEMO_SUPPORT
+diff -Naur old/dict/src/tomboykeybinder.h new/dict/src/tomboykeybinder.h
+--- old/dict/src/tomboykeybinder.h 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/src/tomboykeybinder.h 2012-07-12 22:28:04.337920391 +1000
+@@ -21,7 +21,6 @@
+ #ifndef __TOMBOY_KEY_BINDER_H__
+ #define __TOMBOY_KEY_BINDER_H__
+
+-#include <glib.h>
+
+ G_BEGIN_DECLS
+