aboutsummaryrefslogtreecommitdiffstats
path: root/testing/startup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/startup/APKBUILD')
-rw-r--r--testing/startup/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/testing/startup/APKBUILD b/testing/startup/APKBUILD
index 7c51f346956..6b5608163f8 100644
--- a/testing/startup/APKBUILD
+++ b/testing/startup/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=startup
pkgver=2.0.3
-pkgrel=0
+pkgrel=4
pkgdesc="Event driven task and service manager"
options="!check"
url="https://gitlab.com/chinstrap/startup"
@@ -33,6 +33,7 @@ subpackages="
libupstart:libs
$pkgname-bridge-udev
$pkgname-bridge-dconf
+ $pkgname-fish-completion
"
source="$pkgname-$pkgver.tar.gz::https://gitlab.com/chinstrap/startup/-/archive/$pkgver/startup-$pkgver.tar.gz"
@@ -63,7 +64,10 @@ package() {
# Install fish completion
install -Dm0644 contrib/fish_completion/*.fish \
- -t "$pkgdir"/usr/share/fish/completions
+ -t "$pkgdir"/usr/share/fish/vendor_completions.d
+
+ mkdir -p "$pkgdir"/usr/share/dbus-1/system.d/
+ mv "$pkgdir"/etc/dbus-1/system.d/* "$pkgdir"/usr/share/dbus-1/system.d/
}
tools() {
@@ -74,8 +78,6 @@ tools() {
amove usr/bin/startup-monitor
amove usr/share/icons
amove usr/share/applications
- amove usr/share/fish/completions/initctl2dot.fish
- amove usr/share/fish/completions/startup-monitor.fish
}
dconf() {