aboutsummaryrefslogtreecommitdiffstats
path: root/testing/step-certificates/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/step-certificates/APKBUILD')
-rw-r--r--testing/step-certificates/APKBUILD57
1 files changed, 0 insertions, 57 deletions
diff --git a/testing/step-certificates/APKBUILD b/testing/step-certificates/APKBUILD
deleted file mode 100644
index 9dbb382d8e7..00000000000
--- a/testing/step-certificates/APKBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# Contributor: Adrian L Lange <alpine@p3lim.net>
-# Contributor: Charles Wimmer <charles@wimmer.net>
-# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
-# Maintainer: Dermot Bradley <dermot_bradley@yahoo.com>
-pkgname=step-certificates
-pkgver=0.17.1
-pkgrel=1
-pkgdesc="Online certificate authority and related tools"
-url="https://smallstep.com/certificates/"
-arch="all !s390x !mips !mips64"
-license="Apache-2.0"
-makedepends="
- bash
- go
- go-bindata
- pcsc-lite-dev
- "
-depends="step-cli"
-options="!check" # No tests as fails for Yubikey
-install="$pkgname.pre-install"
-subpackages="
- $pkgname-openrc
- "
-source="$pkgname-$pkgver.tar.gz::https://github.com/smallstep/certificates/archive/v$pkgver.tar.gz
- 01-Makefile-GOFLAGS.patch
- 02-Makefile-yubikey-and-pkcs11-binary.patch
- step-ca.confd
- step-ca.initd
- step-ca.logrotate
- "
-builddir="$srcdir/certificates-$pkgver"
-
-build() {
- make simple
-}
-
-check() {
- make test
-}
-
-package() {
- make DESTDIR="$pkgdir" install
-
- install -m 644 -D "$srcdir"/step-ca.confd "$pkgdir"/etc/conf.d/step-ca
- install -m 755 -D "$srcdir"/step-ca.initd "$pkgdir"/etc/init.d/step-ca
-
- install -m 644 -D "$srcdir"/step-ca.logrotate "$pkgdir"/etc/logrotate.d/step-ca
-}
-
-sha512sums="
-840307ae0d5be78ed7f69770f1d9f2d9ef3681c7f9f855b42bbb5df5074b9273c4b7638d95b3a3f29b577902820fc78e91a417a69b96534d9634add8ef302f43 step-certificates-0.17.1.tar.gz
-5cce04fd9233a1de480426d77c21a5318a9d68926ce63dc6b8b14b2061b73312a685971e695ead40c066a24557414b6a00f8bfbab4e64d1e39679378e8970315 01-Makefile-GOFLAGS.patch
-0b49bda9b0b0df9d9e10ab96405a8eff5b50aaf354b8ce424d4f085ef7b033d98169521f798b27dce3959ea18cf97da365613417c40a3d54779fad7ecc15e3d4 02-Makefile-yubikey-and-pkcs11-binary.patch
-c3a6ac7216643dba6dd54bd709e94e6c2d3ad8c04a342845a8873964e3bbca8f96cf40517628af8a0b8ed861757cf09ccea5a65804ba7849114bc75c3636e5d1 step-ca.confd
-9dd2342434f3330d5ce7a6461a71ac1a40f9e1c17f2fc0599f4882c4ba3497ec09809b84f54828a9db87777e65905aff880f36610b3a157c33b6491cbd7ca82b step-ca.initd
-0af3914768275d26cd25a36ac4b33218429da00e3c719bdd7841507b6dc4a9d8c4db30e502072accc111d25333888e9f310baf8260f07545a083ba13719eb4ed step-ca.logrotate
-"