aboutsummaryrefslogtreecommitdiffstats
path: root/testing/stgit
diff options
context:
space:
mode:
Diffstat (limited to 'testing/stgit')
-rw-r--r--testing/stgit/APKBUILD74
1 files changed, 38 insertions, 36 deletions
diff --git a/testing/stgit/APKBUILD b/testing/stgit/APKBUILD
index 28fd00228f3..3c235590043 100644
--- a/testing/stgit/APKBUILD
+++ b/testing/stgit/APKBUILD
@@ -1,23 +1,25 @@
# Contributor: Joseph Benden <joe@benden.us>
# Maintainer: Joseph Benden <joe@benden.us>
-
pkgname=stgit
-pkgver=0.20
-pkgrel=0
+pkgver=1.3
+pkgrel=5
pkgdesc="Manage a stack of patches using GIT as a backend"
arch="noarch"
url="http://www.procode.org/stgit/"
license="GPL-2.0-or-later"
options="!check" # unit-tests fail due to iconv usage
depends="git python3"
-makedepends="asciidoc xmlto perl"
+makedepends="asciidoc xmlto perl py3-setuptools"
subpackages="
+ $pkgname-pyc
$pkgname-doc
- $pkgname-zsh-completion:zshcomp:noarch
- $pkgname-fish-completion:fishcomp:noarch
- $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion
+ $pkgname-fish-completion
+ $pkgname-bash-completion
+ $pkgname-vim:_vim:noarch
+ $pkgname-emacs:_emacs:noarch
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ctmarinas/stgit/archive/v$pkgver.tar.gz"
+source="https://github.com/stacked-git/stgit/releases/download/v$pkgver/stgit-$pkgver.tar.gz"
prepare() {
default_prepare
@@ -50,39 +52,39 @@ package() {
prefix=/usr \
mandir=/usr/share/man/ \
install install-doc
-}
-bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ # shell completion
+ rm -rf "$pkgdir"/usr/share/stgit/completions
+ install -Dm0644 completion/stgit.bash \
+ "$pkgdir"/usr/share/bash-completion/completions/stgit
+ install -Dm0644 completion/stgit.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_stgit
+ install -Dm0644 completion/stg.fish \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/stg.fish
- mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
- mv "$pkgdir"/usr/share/stgit/completion/stgit.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/stgit
- rmdir -p "$pkgdir"/usr/share/stgit/completion || true
-}
+ # lisp
+ install -Dm0644 contrib/stgit.el -t "$pkgdir"/usr/share/emacs/site-lisp
-zshcomp() {
- depends=""
- pkgdesc="Zsh compltions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
- mkdir -p "$subpkgdir"/usr/share/zsh/site-functions
- mv "$pkgdir"/usr/share/stgit/completion/stgit.zsh \
- "$subpkgdir"/usr/share/zsh/site-functions/_stgit
- rmdir -p "$pkgdir"/usr/share/stgit/completions || true
+ # vim
+ install -Dm0644 contrib/vim/ftdetect/stg.vim -t \
+ "$pkgdir"/usr/share/vim/vimfiles/ftdetect
+ for vimsyntax in contrib/vim/syntax/*.vim; do
+ install -Dm0644 "$vimsyntax" -t "$pkgdir"/usr/share/vim/vimfiles/syntax
+ done
}
-fishcomp() {
- depends=""
- pkgdesc="Fish completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel fish"
+_emacs() {
+ pkgdesc="stg plugin for emacs"
+ install_if="$pkgname=$pkgver-r$pkgrel emacs"
+ amove usr/share/emacs
+}
- mkdir -p "$subpkgdir"/usr/share/fish/completions
- mv "$pkgdir"/usr/share/stgit/completion/stg.fish \
- "$subpkgdir"/usr/share/fish/completions/stg.fish
- rmdir -p "$pkgdir"/usr/share/stgit/completions || true
+_vim() {
+ pkgdesc="vim filetype and syntax for stgit files"
+ install_if="$pkgname=$pkgver-r$pkgrel vim"
+ amove usr/share/vim/vimfiles
}
-sha512sums="0ea60462e1ac5c8329092b774b66caa98230ddc843f0302ceb42ce20e2f3c69b0e011801ebd61f523f7f6ca168bf9dbc5c617e38de4a93b68147a5d8094ba532 stgit-0.20.tar.gz"
+sha512sums="
+3352837aabb83276e7d110fa6a7298a0c9e4e2c325771c7e32c1c3c6dfb7a763d10648858b78129e9365f7bddd33ac1cb28df33a74b6b43564c66f653a59da2c stgit-1.3.tar.gz
+"