aboutsummaryrefslogtreecommitdiffstats
path: root/testing/stone-soup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/stone-soup/APKBUILD')
-rw-r--r--testing/stone-soup/APKBUILD86
1 files changed, 61 insertions, 25 deletions
diff --git a/testing/stone-soup/APKBUILD b/testing/stone-soup/APKBUILD
index e44294d4829..3cca1755bf9 100644
--- a/testing/stone-soup/APKBUILD
+++ b/testing/stone-soup/APKBUILD
@@ -1,36 +1,47 @@
# Contributor: Matthew T Hoare <matthew.t.hoare@gmail.com>
# Maintainer: Matthew T Hoare <matthew.t.hoare@gmail.com>
pkgname=stone-soup
-pkgver=0.26.1
+pkgver=0.31.0
pkgrel=0
pkgdesc="Open-source, single-player, role-playing roguelike game of exploration and treasure-hunting"
url="https://crawl.develz.org"
arch="all"
license="BSD-2-Clause AND BSD-3-Clause AND CC0-1.0 AND MIT AND Zlib AND Apache-2.0 AND BSL-1.0"
-depends="mesa-dri-gallium ttf-dejavu"
-makedepends="freetype-dev glu-dev lua5.1-dev mesa-dev ncurses-dev perl py3-yaml
- python3 sdl2-dev sdl2_image-dev sdl2_mixer-dev sqlite-dev"
+depends="mesa-dri-gallium font-dejavu"
+makedepends="
+ freetype-dev
+ glu-dev
+ lua5.1-dev
+ mesa-dev
+ ncurses-dev
+ perl
+ pngcrush
+ py3-yaml
+ python3
+ sdl2-dev
+ sdl2_image-dev
+ sdl2_mixer-dev
+ sqlite-dev
+ "
options="!check" # no checks
-source="$pkgname-$pkgver.tar.gz::https://github.com/crawl/crawl/archive/$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.xz::https://github.com/crawl/crawl/releases/download/$pkgver/stone_soup-$pkgver-nodeps.tar.xz
crawl.desktop
- crawl-tiles.desktop"
-builddir="$srcdir/crawl-$pkgver/crawl-ref/"
+ crawl-tiles.desktop
+ no-execinfo.patch
+ root-owner.patch
+ "
+builddir="$srcdir/stone_soup-$pkgver"
prepare() {
default_prepare
- # fix backtrace build failure
- sed -i '10s/$/ \&\& (!defined(TARGET_OS_LINUX) || defined(_GLIBC_))/' source/crash.cc
-
- # fix SDL version
- sed -i 's|SDL_main.h|SDL2/&|' source/main.cc
-
- # specify tarball version
- echo "$pkgver" > source/util/release_ver
-
- # adjust makefile to use /usr/bin, owner root:root
- sed -i 's|bin_prefix := bin|bin_prefix := usr/bin|' source/Makefile
- sed -i 's/INSTALL_UGRP := games:games/INSTALL_UGRP := root:root/' source/Makefile
+ # fix version
+ git init .
+ git config user.name a
+ git config user.email 'a@a'
+ git add .
+ git commit -m "$pkgver"
+ git tag $pkgver
# create separate source directories for console and tiles versions
cp -r source console
@@ -39,10 +50,25 @@ prepare() {
build() {
# first build tiles version
- make -C tiles USE_UNICODE=y TILES=y SOUND=y
+ make -C tiles \
+ DESTDIR="$pkgdir" \
+ SAVEDIR="~/.crawl/" \
+ DATADIR="/usr/share/$pkgname/data" \
+ TILES=y \
+ SOUND=y \
+ EXTERNAL_LDFLAGS="$LDFLAGS" \
+ prefix=/usr \
+ bin_prefix=bin
# then build console version
- make -C console USE_UNICODE=y SOUND=y
+ make -C console \
+ DESTDIR="$pkgdir" \
+ SAVEDIR="~/.crawl/" \
+ DATADIR="/usr/share/$pkgname/data" \
+ SOUND=y \
+ EXTERNAL_LDFLAGS="$LDFLAGS" \
+ prefix=/usr \
+ bin_prefix=bin
}
package() {
@@ -51,8 +77,11 @@ package() {
DESTDIR="$pkgdir" \
SAVEDIR="~/.crawl/" \
DATADIR="/usr/share/$pkgname/data" \
- USE_UNICODE=y \
TILES=y \
+ SOUND=y \
+ EXTERNAL_LDFLAGS="$LDFLAGS" \
+ prefix=/usr \
+ bin_prefix=bin \
install
# rename tiles executable to avoid clashing with console crawl
@@ -63,7 +92,10 @@ package() {
DESTDIR="$pkgdir" \
SAVEDIR="~/.crawl/" \
DATADIR="/usr/share/$pkgname/data" \
- USE_UNICODE=y \
+ SOUND=y \
+ EXTERNAL_LDFLAGS="$LDFLAGS" \
+ prefix=/usr \
+ bin_prefix=bin \
install
# install icon and .desktop files
@@ -75,6 +107,10 @@ package() {
"$pkgdir"/usr/share/applications/crawl-tiles.desktop
}
-sha512sums="c2fa089b700c0dcbc2b8afa3410144cbf99f9bbc3cc5481baf0c3f281dcce11ef34165dfa561d17320784057bfdb90310df9c64242b6936d478b33ad27298d17 stone-soup-0.26.1.tar.gz
+sha512sums="
+f0027144fb538f605c9c8e1987d689e79341e19dc393971c86cfc3ec7aa4d62d5abddc4a38e05d8b2d047098b64cdcc0dd003b4e92ecdab09dae8a16a76043a6 stone-soup-0.31.0.tar.xz
8e14cfa97f8765126050b14dc85cee60a6f00fe458b21714a34403872fbfc11f7b1d42897424936fbaaba5ad0fed76c10a90c4c144076c9526f7e653c3dbbca0 crawl.desktop
-d8c64f6c388f3551e6744b0fccfa0fc7148cb839174a5ed464fdb46511f8e0f4e66cb297f91446e5e098cbacddaba88476f499fb50e6c39e6563fe8231dafe54 crawl-tiles.desktop"
+d8c64f6c388f3551e6744b0fccfa0fc7148cb839174a5ed464fdb46511f8e0f4e66cb297f91446e5e098cbacddaba88476f499fb50e6c39e6563fe8231dafe54 crawl-tiles.desktop
+3fbd434786edb456b27942cd1aa8034241359b701afadea73f54c3622b1ccaf6f7f3a1c01b8d0d3e8388baaed38b205c4013da35a00974848af5b27f6141c379 no-execinfo.patch
+9b785d08e722a8fee4f1fb624b77110cfdaa6d74422d874d53a13064b1054463738aceb4a40c83a1c5932c07f76186f1136bb60c00ed96e10e225edcb4722636 root-owner.patch
+"