aboutsummaryrefslogtreecommitdiffstats
path: root/testing/streamlink/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/streamlink/APKBUILD')
-rw-r--r--testing/streamlink/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/streamlink/APKBUILD b/testing/streamlink/APKBUILD
deleted file mode 100644
index 9dca9550892..00000000000
--- a/testing/streamlink/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Robert Sacks <robert@sacks.email>
-# Maintainer: Robert Sacks <robert@sacks.email>
-pkgname=streamlink
-pkgver=2.0.0
-pkgrel=2
-pkgdesc="CLI for extracting streams from various websites to a video player of your choosing"
-options="!check" # Locale-specific tests fail
-url="https://streamlink.github.io/"
-arch="noarch"
-license="BSD-2-Clause"
-depends="python3 py3-pycryptodome py3-pycountry py3-requests py3-pysocks
- py3-websocket-client py3-isodate rtmpdump"
-makedepends="py3-setuptools py3-sphinx py3-recommonmark"
-checkdepends="py3-pytest py3-pytest-cov py3-codecov py3-coverage py3-freezegun
- py3-requests-mock py3-mock"
-subpackages="$pkgname-doc"
-source="streamlink-$pkgver.tar.gz::https://github.com/streamlink/streamlink/archive/$pkgver.tar.gz"
-
-build() {
- export STREAMLINK_USE_PYCOUNTRY=1
- python3 setup.py build
- python3 setup.py build_sphinx -b man
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- install -Dm644 build/sphinx/man/streamlink.1 \
- "$pkgdir"/usr/share/man/man1/streamlink.1
-}
-
-sha512sums="908d6ae7c6cfc81ed06443b36cf947b921c3130bfcc16f4c7b5369bde68b03689c2188b23d3522af4328b7af1531a04bbebc05d6b99f11e0542a9d03402718b1 streamlink-2.0.0.tar.gz"