aboutsummaryrefslogtreecommitdiffstats
path: root/testing/stylua/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/stylua/APKBUILD')
-rw-r--r--testing/stylua/APKBUILD40
1 files changed, 0 insertions, 40 deletions
diff --git a/testing/stylua/APKBUILD b/testing/stylua/APKBUILD
deleted file mode 100644
index e7c41899ff3..00000000000
--- a/testing/stylua/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: psykose <alice@ayaya.dev>
-# Maintainer: psykose <alice@ayaya.dev>
-pkgname=stylua
-pkgver=0.11.3
-pkgrel=0
-pkgdesc="Opinionated Lua 5.1/5.2/luau code formatter"
-url="https://github.com/JohnnyMorganz/StyLua"
-arch="all !s390x !riscv64" # blocked by cargo
-license="MPL-2.0"
-makedepends="cargo"
-source="$pkgname-$pkgver.tar.gz::https://github.com/JohnnyMorganz/StyLua/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/StyLua-$pkgver"
-
-prepare() {
- default_prepare
- cargo fetch --locked
-}
-
-build() {
- cat >> Cargo.toml <<- EOF
- [profile.release]
- codegen-units = 1
- lto = true
- opt-level = "s"
- panic = "abort"
- EOF
- cargo build --release --frozen
-}
-
-check() {
- cargo test --frozen
-}
-
-package() {
- install -Dm755 "$builddir"/target/release/stylua \
- "$pkgdir"/usr/bin/stylua
-}
-sha512sums="
-dff84e1dbe40884a477e1f9cb6964937e7e615a9ae15f73a5eb336d40ea6ef81e2284a81e1b7027b00264dfe84a76663d2388833c0296d6e963aa23410850543 stylua-0.11.3.tar.gz
-"