aboutsummaryrefslogtreecommitdiffstats
path: root/testing/supermin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/supermin/APKBUILD')
-rw-r--r--testing/supermin/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/testing/supermin/APKBUILD b/testing/supermin/APKBUILD
index dc3855ad3ba..9059e660578 100644
--- a/testing/supermin/APKBUILD
+++ b/testing/supermin/APKBUILD
@@ -1,11 +1,11 @@
# Contributor:
# Maintainer: Fathi Boudra <fathi.boudra@linaro.org>
pkgname=supermin
-pkgver=5.1.20
-pkgrel=1
+pkgver=5.2.2
+pkgrel=2
pkgdesc="tool for building supermin appliances"
-url="http://libguestfs.org/"
-arch="x86_64"
+url="https://libguestfs.org/"
+arch="all !riscv64 !loongarch64" # limited by ocaml aport
license="GPL-2.0-or-later"
depends="cpio e2fsprogs"
makedepends="
@@ -17,11 +17,18 @@ makedepends="
perl
"
subpackages="$pkgname-doc"
-source="http://download.libguestfs.org/supermin/$pkgname-$pkgver.tar.gz"
+source="https://download.libguestfs.org/supermin/5.2-stable/supermin-$pkgver.tar.gz"
options="!check" # Disable tests as they fail under Alpine
+# 32-bit archs
+case "$CARCH" in
+ arm*|x86) options="$options textrels" ;;
+esac
+
build() {
./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
--prefix=/usr \
--mandir=/usr/share/man \
--disable-network-tests
@@ -39,4 +46,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ccc9ada98593f91399b323f0beb027185874f82547a1df4274c1206a9b6d4465e98b7aef5618274d41fb902747f6843fd2cc6192a4ea8526811261ac5a16848e supermin-5.1.20.tar.gz"
+sha512sums="
+c2a0758d6807155e226e0d9e460f8e72efbdb9d715ce7b22389dc3f4dbe34ff0d0c1afeb8e2852678602ba7ec3a700926b9c0078fc539765151b1f0167e01059 supermin-5.2.2.tar.gz
+"