aboutsummaryrefslogtreecommitdiffstats
path: root/testing/telegram-desktop/range-v3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/telegram-desktop/range-v3.patch')
-rw-r--r--testing/telegram-desktop/range-v3.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/telegram-desktop/range-v3.patch b/testing/telegram-desktop/range-v3.patch
new file mode 100644
index 00000000000..3a444c04a7f
--- /dev/null
+++ b/testing/telegram-desktop/range-v3.patch
@@ -0,0 +1,24 @@
+diff --git a/cmake/external/ranges/CMakeLists.txt b/cmake/external/ranges/CMakeLists.txt
+index 4c75ecb..fc6febc 100644
+--- a/cmake/external/ranges/CMakeLists.txt
++++ b/cmake/external/ranges/CMakeLists.txt
+@@ -7,15 +7,9 @@
+ add_library(external_ranges INTERFACE IMPORTED GLOBAL)
+ add_library(desktop-app::external_ranges ALIAS external_ranges)
+
++find_package(range-v3 REQUIRED)
++
+ target_include_directories(external_ranges SYSTEM
+ INTERFACE
+- ${libs_loc}/range-v3/include
++ ${RANGE_V3_INCLUDE_DIRS}
+ )
+-
+-if (WIN32)
+- target_compile_options(external_ranges
+- INTERFACE
+- /experimental:preprocessor # need for range-v3 see https://github.com/ericniebler/range-v3#supported-compilers
+- /wd5105 # needed for `/experimental:preprocessor`, suppressing C5105 "macro expansion producing 'defined' has undefined behavior"
+- )
+-endif()
+\ No newline at end of file