aboutsummaryrefslogtreecommitdiffstats
path: root/testing/telegram-desktop
diff options
context:
space:
mode:
Diffstat (limited to 'testing/telegram-desktop')
-rw-r--r--testing/telegram-desktop/0016-no-gtk2.patch30
-rw-r--r--testing/telegram-desktop/APKBUILD11
2 files changed, 37 insertions, 4 deletions
diff --git a/testing/telegram-desktop/0016-no-gtk2.patch b/testing/telegram-desktop/0016-no-gtk2.patch
new file mode 100644
index 00000000000..12317a88477
--- /dev/null
+++ b/testing/telegram-desktop/0016-no-gtk2.patch
@@ -0,0 +1,30 @@
+diff --git a/Telegram/SourceFiles/platform/linux/linux_libs.cpp b/Telegram/SourceFiles/platform/linux/linux_libs.cpp
+index f8d74fee1..c9d059fa6 100644
+--- a/Telegram/SourceFiles/platform/linux/linux_libs.cpp
++++ b/Telegram/SourceFiles/platform/linux/linux_libs.cpp
+@@ -240,24 +240,12 @@ void start() {
+ indicatorLoaded = setupAppIndicator(lib_indicator);
+ }
+ }
+- if ((!gtkLoaded || !indicatorLoaded) && !isWayland) {
+- if (loadLibrary(lib_indicator, "ayatana-appindicator", 1) || loadLibrary(lib_indicator, "appindicator", 1)) {
+- if (loadLibrary(lib_gtk, "gtk-x11-2.0", 0)) {
+- gtkLoaded = indicatorLoaded = false;
+- gtkLoaded = setupGtkBase(lib_gtk);
+- indicatorLoaded = setupAppIndicator(lib_indicator);
+- }
+- }
+- }
+
+ // If no appindicator, try at least load gtk.
+ if (!gtkLoaded && !indicatorLoaded) {
+ if (loadLibrary(lib_gtk, "gtk-3", 0)) {
+ gtkLoaded = setupGtkBase(lib_gtk);
+ }
+- if (!gtkLoaded && !isWayland && loadLibrary(lib_gtk, "gtk-x11-2.0", 0)) {
+- gtkLoaded = setupGtkBase(lib_gtk);
+- }
+ }
+
+ if (gtkLoaded) {
+
diff --git a/testing/telegram-desktop/APKBUILD b/testing/telegram-desktop/APKBUILD
index b04c3cd36c9..55faee72fe9 100644
--- a/testing/telegram-desktop/APKBUILD
+++ b/testing/telegram-desktop/APKBUILD
@@ -11,13 +11,13 @@ _libtgvoip_commit=d4a0f719ffd8d29e88474f67abc9fc862661c3b9
_rlottie_commit=589db026ec211bc4979e3bffe074f6e48ce7cedc
_variant_commit=550ac2f159ca883d360c196149b466955c77a573
_xxhash_commit=7cc9639699f64b750c0b82333dced9ea77e8436e
-pkgrel=0
+pkgrel=1
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
url="https://desktop.telegram.org/"
arch="all !s390x" # ARM are failing due to range-v3
license="GPL-3.0-or-later WITH OpenSSL"
-depends="qt5-qtimageformats"
+depends="qt5-qtimageformats libappindicator"
makedepends="
gyp
grep
@@ -43,6 +43,8 @@ makedepends="
pulseaudio-dev
qtchooser
range-v3-dev
+ libdbusmenu-glib-dev
+ libappindicator-dev
"
source="
$pkgname-$pkgver.tar.gz::https://github.com/telegramdesktop/tdesktop/archive/v$pkgver.tar.gz
@@ -65,6 +67,7 @@ source="
0013-lz4.patch
0014-clock_gettime.patch
0015-revert-headers.patch
+ 0016-no-gtk2.patch
"
builddir="$srcdir/tdesktop-$pkgver"
@@ -115,7 +118,6 @@ build() {
export GYP_DEFINES="TDESKTOP_DISABLE_CRASH_REPORTS,TDESKTOP_DISABLE_AUTOUPDATE"
export GYP_DEFINES="${GYP_DEFINES},TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME"
export GYP_DEFINES="${GYP_DEFINES},TDESKTOP_DISABLE_DESKTOP_FILE_GENERATION"
- export GYP_DEFINES="${GYP_DEFINES},TDESKTOP_DISABLE_GTK_INTEGRATION"
export EXTRA_FLAGS="-Winvalid-pch -O2"
export CPPFLAGS="$CPPFLAGS $EXTRA_FLAGS"
export CXXFLAGS="$CXXFLAGS $EXTRA_FLAGS"
@@ -172,4 +174,5 @@ d4ef17600e095b753bcbc4df0078cc025dd235056a8f4946183fc5416e0452bceac020badda60221
7d5642672f42f435e206acd047a20b7e38346ed95548f16c0059913546e4e4f54a58927fccb8c1da8e43b6a691bbce2a9608d0db032774d7874d4800e7202d53 0010-libtgvoip.patch
aaff642634f42ba017ac94a2c2cd7df595d0a304a62f5f46dbec82e2c88c00a8cfd6346b2809013228f47f301aedf94e10e77197eebefa26b6df81267e8b1a64 0013-lz4.patch
ab6ef737712cbc934a908aabb57332a4d207c223f50f0108668b8c3c9fd07cd840845ef99c0dc18dca2139f476fcb0309f99058af710ffaf1272023d1d2f1ab4 0014-clock_gettime.patch
-d564ee17a610864b1708f7ad1050804e24921b8bb3c4da9713f804b3738ba63d6ee0e594b3fe7c28d0fb9a082a22021b1c7f2b60498265bbca08e89775a4f60a 0015-revert-headers.patch"
+d564ee17a610864b1708f7ad1050804e24921b8bb3c4da9713f804b3738ba63d6ee0e594b3fe7c28d0fb9a082a22021b1c7f2b60498265bbca08e89775a4f60a 0015-revert-headers.patch
+b5ecc802ea8cf7e33b29d6d63496537a83e9410ed95288446d783ab2899f7e499fbd02663705b1b85381760468063f6852ae212b141863304e7f71b9dcaa7149 0016-no-gtk2.patch"