aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tepl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tepl/APKBUILD')
-rw-r--r--testing/tepl/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/tepl/APKBUILD b/testing/tepl/APKBUILD
new file mode 100644
index 00000000000..ab26a040e97
--- /dev/null
+++ b/testing/tepl/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=tepl
+pkgver=4.2.0
+pkgrel=0
+pkgdesc="Text editor product line"
+url="https://wiki.gnome.org/Projects/Tepl"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="amtk-dev glib-dev gtksourceview4-dev gtk+3.0-dev libxml2-dev
+ uchardet-dev vala gobject-introspection-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # needs DISPLAY
+source="https://download.gnome.org/sources/tepl/${pkgver%.*}/tepl-${pkgver}.tar.xz"
+builddir="$srcdir/tepl-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="32f69c6f0942a82e6b7f94eba776d55dce2af1c8e4c7abadf6af38a0a5abb0a94f0c426d5ec727b8eb478406ba113728b771597c2c84e508b8ccb113a74eab3d tepl-4.2.0.tar.xz"