aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thunarx-python/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/thunarx-python/APKBUILD')
-rw-r--r--testing/thunarx-python/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/thunarx-python/APKBUILD b/testing/thunarx-python/APKBUILD
new file mode 100644
index 00000000000..93f01145d73
--- /dev/null
+++ b/testing/thunarx-python/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Saijin-Naib <2107-Saijin-Naib@users.gitlab.alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=thunarx-python
+pkgver=0.5.2
+pkgrel=2
+pkgdesc="Python bindings for the Thunar Extension Framework"
+url="https://wiki.xfce.org/thunarx-python"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="gtk-doc python3-dev py3-gobject3-dev thunar-dev"
+subpackages="$pkgname-doc"
+source="https://archive.xfce.org/src/bindings/thunarx-python/${pkgver%.*}/thunarx-python-$pkgver.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+# Run in-built tests as per the INSTALL instructions
+check() {
+ make check
+ make installcheck
+}
+
+package() {
+ make install DESTDIR="$pkgdir"
+}
+sha512sums="
+49d009c84d69f0a1938ed6cb46fe04326c7323edecd79f6d9978ce2306fb95f20c901174f1cea31d5e436c85537efcb79c8613be857a3e4143f7b55b895616b6 thunarx-python-0.5.2.tar.bz2
+"