aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tldr-python-client/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tldr-python-client/APKBUILD')
-rw-r--r--testing/tldr-python-client/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/tldr-python-client/APKBUILD b/testing/tldr-python-client/APKBUILD
new file mode 100644
index 00000000000..d1648bbcf91
--- /dev/null
+++ b/testing/tldr-python-client/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Keith Toh <ktprograms@gmail.com>
+pkgname=tldr-python-client
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Command line client for tldr, a collection of simplified and community-driven man pages"
+url="https://github.com/tldr-pages/tldr-python-client"
+arch="noarch"
+license="MIT"
+depends="python3 py3-shtab py3-colorama py3-termcolor"
+makedepends="py3-setuptools py3-sphinx py3-sphinx-argparse"
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tldr-pages/tldr-python-client/archive/refs/tags/$pkgver.tar.gz"
+options="!check" # string compare fails now
+
+build() {
+ make -C docs/ man
+ python3 setup.py build
+}
+
+check() {
+ # test_error_message needs network access
+ pytest -v -k "not test_error_message"
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+ install -Dm644 LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname/
+}
+
+sha512sums="
+1535979548b49cd8b0312f2cd11f69ba3f710e16a27c074dc5a8cb5617d7f343df30ba01a83388b460508ab519045140852767bfc8ff1189d612d71a3d35d76b tldr-python-client-3.2.0.tar.gz
+"