aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vdirsyncer
diff options
context:
space:
mode:
Diffstat (limited to 'testing/vdirsyncer')
-rw-r--r--testing/vdirsyncer/01-python-click.patch29
-rw-r--r--testing/vdirsyncer/APKBUILD21
-rw-r--r--testing/vdirsyncer/vdirsyncer-0.16.8-python_getiterator_deprecation.patch22
3 files changed, 8 insertions, 64 deletions
diff --git a/testing/vdirsyncer/01-python-click.patch b/testing/vdirsyncer/01-python-click.patch
deleted file mode 100644
index 772605bf0d2..00000000000
--- a/testing/vdirsyncer/01-python-click.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-# See https://github.com/pimutils/vdirsyncer/issues/828
-diff --git i/setup.py w/setup.py
-index 653be04..aaa4c2d 100644
---- i/setup.py
-+++ w/setup.py
-@@ -11,8 +11,8 @@ from setuptools import Command, find_packages, setup
-
- requirements = [
- # https://github.com/mitsuhiko/click/issues/200
-- 'click>=5.0,<6.0',
-- 'click-log>=0.3.0, <0.4.0',
-+ 'click>=5.0',
-+ 'click-log>=0.3.0',
-
- # https://github.com/pimutils/vdirsyncer/issues/478
- 'click-threading>=0.2',
-diff --git i/tests/system/cli/test_sync.py w/tests/system/cli/test_sync.py
-index 97e21e8..54fa201 100644
---- i/tests/system/cli/test_sync.py
-+++ w/tests/system/cli/test_sync.py
-@@ -123,7 +123,7 @@ def test_verbosity(tmpdir, runner):
- runner.write_with_general('')
- result = runner.invoke(['--verbosity=HAHA', 'sync'])
- assert result.exception
-- assert 'invalid value for "--verbosity"' in result.output.lower()
-+ assert "invalid value for '--verbosity'" in result.output.lower()
-
-
- def test_collections_cache_invalidation(tmpdir, runner):
diff --git a/testing/vdirsyncer/APKBUILD b/testing/vdirsyncer/APKBUILD
index 3a375ac2ef8..5034905d0ac 100644
--- a/testing/vdirsyncer/APKBUILD
+++ b/testing/vdirsyncer/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=vdirsyncer
_pyname=$pkgname
-pkgver=0.16.8
-pkgrel=1
+pkgver=0.18.0
+pkgrel=0
pkgdesc="CLI Synchronization for CalDAV and CardDAV"
url="http://vdirsyncer.pimutils.org"
arch="noarch"
@@ -20,17 +20,14 @@ depends="
makedepends="py3-setuptools py3-setuptools_scm py3-sphinx"
checkdepends="
py3-pytest
+ py3-pytest-cov
py3-hypothesis
py3-pytest-localserver
py3-subtesthack
py3-werkzeug
"
subpackages="$pkgname-doc"
-source="
- https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz
- 01-python-click.patch
- vdirsyncer-0.16.8-python_getiterator_deprecation.patch
- "
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
build() {
python3 setup.py build
@@ -38,9 +35,7 @@ build() {
}
check() {
- # test_create_collections fails inexplicably
- local pytest_args="-v --deselect=tests/system/cli/test_sync.py::test_create_collections"
- make DETERMINISTIC_TESTS=true PYTEST_ARGS="$pytest_args" test
+ make DETERMINISTIC_TESTS=true PYTEST_ADDOPTS="" test
}
package() {
@@ -48,6 +43,6 @@ package() {
install -Dm644 build/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
}
-sha512sums="12cb50f592085af37bd9c4207c0d31fdd38fc2a44712eb6288b12e7e7ee9af82070d1d405fa9579e935e545e6c92aafb6f8334ebde4976c4eb9412e78e7c5ada vdirsyncer-0.16.8.tar.gz
-5a1e718c6e7e3cc751ce4a2558dfbd0635d7aec1aef1d7de424887e3df7688c4c30f7c416bd9a4290b572c24b932a3643234ab54fd9d43484d626f5a154f8eda 01-python-click.patch
-904ff0d66ab00593c123713469e884faff238df626014e6a9fb77ea1d97cd3798b9e638991aaa78a45c16ea938ae8852c9c69381ac15e8b97752c9c19869dc3c vdirsyncer-0.16.8-python_getiterator_deprecation.patch"
+sha512sums="
+7fb3d0f7d982d8390d278de1a620231e6ead1ec64057c5dbac98dcff491fa3e6b9ed8ba953995458e393aab73b0b9ab8ba14010e06f90a04d8ee2c28c7c7fbfd vdirsyncer-0.18.0.tar.gz
+"
diff --git a/testing/vdirsyncer/vdirsyncer-0.16.8-python_getiterator_deprecation.patch b/testing/vdirsyncer/vdirsyncer-0.16.8-python_getiterator_deprecation.patch
deleted file mode 100644
index bdcb7f25dfb..00000000000
--- a/testing/vdirsyncer/vdirsyncer-0.16.8-python_getiterator_deprecation.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 7577fa21177442aacc2d86640ef28cebf1c4aaef Mon Sep 17 00:00:00 2001
-From: Hugo Osvaldo Barrera <hugo@barrera.io>
-Date: Tue, 9 Jun 2020 17:04:46 +0200
-Subject: [PATCH] Update usage of deprecated method
-
----
- vdirsyncer/storage/dav.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/vdirsyncer/storage/dav.py b/vdirsyncer/storage/dav.py
-index 07d164fb..a7e2422c 100644
---- a/vdirsyncer/storage/dav.py
-+++ b/vdirsyncer/storage/dav.py
-@@ -124,7 +124,7 @@ def _merge_xml(items):
- return None
- rv = items[0]
- for item in items[1:]:
-- rv.extend(item.getiterator())
-+ rv.extend(item.iter())
- return rv
-
-