aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vera++
diff options
context:
space:
mode:
Diffstat (limited to 'testing/vera++')
-rw-r--r--testing/vera++/APKBUILD6
-rw-r--r--testing/vera++/boost-python.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/testing/vera++/APKBUILD b/testing/vera++/APKBUILD
index bbad5d7d988..5101e4c7703 100644
--- a/testing/vera++/APKBUILD
+++ b/testing/vera++/APKBUILD
@@ -7,9 +7,10 @@ pkgdesc="A tool for verification, analysis and transformation of C++ source code
url="https://bitbucket.org/verateam/vera/"
arch="all"
license="Boost"
-makedepends="cmake boost-dev python2-dev tcl-dev"
+makedepends="cmake boost-dev boost-static python2-dev tcl-dev"
source="https://bitbucket.org/verateam/vera/downloads/$pkgname-$pkgver.tar.gz
- ruledump.patch" # see https://bitbucket.org/verateam/vera/issues/73/ruledump-test-fails-on-rhel7-when-built-in
+ boost-python.patch
+ ruledump.patch" # see https://bitbucket.org/verateam/vera/issues/73/ruledump-test-fails-on-rhel7-when-built-in
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -29,4 +30,5 @@ package() {
}
sha512sums="4057deaa45439b4965aee9810ffa429e984fe201173ac87fa8cdc7c39f3f8dd258abf550433d4fb0c6751aaf26f564349587e191d2797e5b318a46f0b5fb5a9e vera++-1.3.0.tar.gz
+0f8a6c4de5d875e9871f9bb8e26ffc67df3c6dc9a5369916b4d405c3f0e938d2a454ae29e53b07a50a54464e007218e8afe4190b767ee8153d1508a111b66f3f boost-python.patch
bf51c7407343e89acb629853ada5715d70833ae1ac798c0b2322dc6f0ead9f30b988ee5ab0827d5f1d4d84caf8d219df02c2483eea2927c84e5a284a9ed4e053 ruledump.patch"
diff --git a/testing/vera++/boost-python.patch b/testing/vera++/boost-python.patch
new file mode 100644
index 00000000000..9b80641a210
--- /dev/null
+++ b/testing/vera++/boost-python.patch
@@ -0,0 +1,13 @@
+diff --git a/src/boost.cmake b/src/boost.cmake
+index 37ecc13..3be4848 100644
+--- a/src/boost.cmake
++++ b/src/boost.cmake
+@@ -8,7 +8,7 @@ mark_as_advanced(VERA_USE_SYSTEM_BOOST)
+
+ set(boostLibs filesystem system program_options regex wave)
+ if(VERA_PYTHON)
+- list(APPEND boostLibs python)
++ list(APPEND boostLibs python27)
+ endif()
+
+ if(VERA_USE_SYSTEM_BOOST)