aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wireguard-go/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/wireguard-go/APKBUILD')
-rw-r--r--testing/wireguard-go/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/wireguard-go/APKBUILD b/testing/wireguard-go/APKBUILD
new file mode 100644
index 00000000000..5308ead2788
--- /dev/null
+++ b/testing/wireguard-go/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Stefan Reiff <kroko87@hotmail.com>
+# Maintainer: Stefan Reiff <kroko87@hotmail.com>
+pkgname=wireguard-go
+pkgver=0.0.20230223
+pkgrel=4
+pkgdesc="Next generation secure network tunnel: userspace implementation in go"
+url="https://www.wireguard.com"
+license="GPL-2.0-only"
+arch="all"
+makedepends="go"
+depends="wireguard-tools-wg wireguard-tools-wg-quick"
+subpackages="$pkgname-doc"
+options="!check"
+source="https://git.zx2c4.com/wireguard-go/snapshot/wireguard-go-$pkgver.tar.xz"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="
+221ecea400fdfdfd564d8ab3b1939cab289b28a00c8d2e8e41bd56484f09d66e20a3dd34dc81471e7fc5133bebffc621be984b8a8d3475a0e4b08daa350d5583 wireguard-go-0.0.20230223.tar.xz
+"