aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xonsh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/xonsh/APKBUILD')
-rw-r--r--testing/xonsh/APKBUILD58
1 files changed, 47 insertions, 11 deletions
diff --git a/testing/xonsh/APKBUILD b/testing/xonsh/APKBUILD
index 8aade2983b5..8d4e5a899c6 100644
--- a/testing/xonsh/APKBUILD
+++ b/testing/xonsh/APKBUILD
@@ -1,31 +1,67 @@
+# Contributor: Hoang Nguyen <folliekazetani@protonmail.com>
# Contributor: vinnie <fz12345@gmail.com>
# Maintainer: vinnie <fz12345@gmail.com>
pkgname=xonsh
-pkgver=0.10.1
-pkgrel=0
+pkgver=0.15.1
+pkgrel=1
pkgdesc="Python-powered, cross-platform, Unix-gazing shell"
url="https://xon.sh"
arch="noarch"
license="BSD-2-Clause"
-options="!check" #flake8-docstrings missing, maybe later
depends="
- py3-pygments>=2.2
- py3-prompt_toolkit>=3.0
py3-distro
- py3-setproctitle
+ py3-prompt_toolkit>=3.0
+ py3-pygments>=2.2
+ py3-pyperclip
+ py3-ujson
+ "
+makedepends="py3-setuptools py3-gpep517 py3-installer py3-wheel"
+# man-db with groff-1.23.0 breaks "test_man.py" due to escape codes in output
+checkdepends="
+ mandoc
+ py3-pip
+ py3-pyte
+ py3-pytest
+ py3-pytest-mock
+ py3-pytest-rerunfailures
+ py3-pytest-subprocess
+ py3-pytest-timeout
+ py3-virtualenv
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xonsh/xonsh/archive/$pkgver.tar.gz
+ no-col.patch
"
-makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/xonsh/xonsh/archive/$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest \
+ --ignore=tests/test_integrations.py \
+ --ignore=tests/test_pipelines.py \
+ --ignore=tests/test_ptk_shell.py \
+ --ignore=tests/completers/test_bash_completer.py \
+ --ignore=tests/procs/test_specs.py \
+ --deselect tests/test_man.py::test_man_completion
+}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+
+ # The build process appends dirty bit into the version string
+ # if a git repo is detected
+ sed -i "s/^\(__version__ =\).*/\1 \"$pkgver\"/" \
+ "$pkgdir"/usr/lib/python*/site-packages/xonsh/__init__.py
}
sha512sums="
-6ccfa4fd30fac307b27db51f868e9516986c85831bc89fa72dcc28633fa429b928c09b8ff5bb55b86fc6e05f0a8e9ebe8810dcfac11fd97ae42bbd2e1aafc8a4 xonsh-0.10.1.tar.gz
+5a8640a80c8aa1a08cabcd643880603ddf9d1181ca1dfb396b5970fb59205a19be4fbd5ff8f0a36779fd25d7204748ad2426f311b7a9e7b954fc3a541a1e2131 xonsh-0.15.1.tar.gz
+56e6548dde6faaa70e000f0d49a260ca0fe5297b0ec0abb1ab2cb0c22154479a957155f06037b91d9fda3736f3c7935d019a6c45adf506334e5940dfd8ac37d1 no-col.patch
"