aboutsummaryrefslogtreecommitdiffstats
path: root/testing/z/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/z/APKBUILD')
-rw-r--r--testing/z/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/z/APKBUILD b/testing/z/APKBUILD
new file mode 100644
index 00000000000..400501a3b1e
--- /dev/null
+++ b/testing/z/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Anirudh Oppiliappan <x@icyphox.sh>
+# Maintainer: Anirudh Oppiliappan <x@icyphox.sh>
+pkgname="z"
+pkgver="1.11"
+pkgrel=0
+pkgdesc="Tracks your most used directories, based on 'frecency'"
+url="https://github.com/rupa/z"
+arch="noarch"
+license="WTFPL"
+install="$pkgname.post-install"
+options="!check" # No testsuite
+source="z-$pkgver.tar.gz::https://github.com/rupa/z/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-doc"
+
+package() {
+ install -Dm 644 z.sh "$pkgdir"/usr/share/$pkgname/z.sh
+ sed -i z.1 -e 's:/path/to/z.sh:/usr/share/"$pkgname"/z.sh:g'
+ install -Dm 644 z.1 "$pkgdir"/usr/share/man/man1/z.1
+}
+
+sha512sums="e8463f8fe2781ff12814e47b1764ddc46875a3a01c0499cb174473df16ba28ea16c2577f7ec27a088c5bd98775ac29f81190b3131d4a953315f01be4e2d548c5 z-1.11.tar.gz"