aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zfsnap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/zfsnap/APKBUILD')
-rw-r--r--testing/zfsnap/APKBUILD59
1 files changed, 0 insertions, 59 deletions
diff --git a/testing/zfsnap/APKBUILD b/testing/zfsnap/APKBUILD
deleted file mode 100644
index 7142b6e4fe1..00000000000
--- a/testing/zfsnap/APKBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# Contributor: Shyam Sunder <sgsunder1@gmail.com>
-# Maintainer: Shyam Sunder <sgsunder1@gmail.com>
-pkgname="zfsnap"
-pkgver="2.0.0b3"
-pkgrel=0
-pkgdesc="A portable, performant script to make rolling ZFS snapshots easy"
-url="https://www.zfsnap.org/"
-arch="noarch !armhf !armv7" # Limited by zfs
-license="BSD-3-Clause"
-depends="zfs"
-options="!check" # no unit tests, only consists of shell scripts
-subpackages="
- $pkgname-doc
- $pkgname-bash-completion:bashcomp:noarch
- $pkgname-zsh-completion:zshcomp:noarch
- "
-source="https://github.com/zfsnap/zfsnap/archive/v2.0.0-beta3.tar.gz"
-builddir="$srcdir/$pkgname-2.0.0-beta3"
-
-prepare() {
- default_prepare
- sed -i \
- -e 's#/sbin/zfs#/usr/sbin/zfs#g' \
- -e 's#/sbin/zpool#/usr/sbin/zpool#g' \
- "$builddir"/share/zfsnap/core.sh
-}
-
-package() {
- install -Dm755 "$builddir"/sbin/zfsnap.sh \
- "$pkgdir"/usr/sbin/zfsnap
- install -Dm755 "$builddir"/share/zfsnap/core.sh \
- "$pkgdir"/usr/share/zfsnap/core.sh
- install -Dm755 "$builddir"/share/zfsnap/commands/destroy.sh \
- "$pkgdir"/usr/share/zfsnap/commands/destroy.sh
- install -Dm755 "$builddir"/share/zfsnap/commands/recurseback.sh \
- "$pkgdir"/usr/share/zfsnap/commands/recurseback.sh
- install -Dm755 "$builddir"/share/zfsnap/commands/snapshot.sh \
- "$pkgdir"/usr/share/zfsnap/commands/snapshot.sh
- install -Dm644 "$builddir"/man/man8/zfsnap.8 \
- "$pkgdir"/usr/share/man/man8/zfsnap.8
-}
-
-bashcomp() {
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- install -Dm644 "$builddir"/completion/$pkgname-completion.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
-}
-
-zshcomp() {
- pkgdesc="Zsh completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
- install -Dm644 "$builddir"/completion/$pkgname-completion.zsh \
- "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
-}
-
-sha512sums="85df793abd97a3db26fcb9d779627ea295b2132dc462c3b1afc70a877d8093196992a7912957157555714c5f1e07ae1694e7fbed9ebae2482fd5f2d846eaf694 v2.0.0-beta3.tar.gz"