aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zsh-syntax-highlighting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/zsh-syntax-highlighting/APKBUILD')
-rw-r--r--testing/zsh-syntax-highlighting/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/zsh-syntax-highlighting/APKBUILD b/testing/zsh-syntax-highlighting/APKBUILD
index 476ed0e7e34..36479b966ca 100644
--- a/testing/zsh-syntax-highlighting/APKBUILD
+++ b/testing/zsh-syntax-highlighting/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Dawid Dziurla <dawidd0811@gmail.com>
# Maintainer: Dawid Dziurla <dawidd0811@gmail.com>
pkgname=zsh-syntax-highlighting
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=0
pkgdesc="Fish shell like syntax highlighting for Zsh"
url="https://github.com/zsh-users/zsh-syntax-highlighting"
@@ -11,17 +11,21 @@ depends="zsh"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
-options="!check" # no tests
build() {
cd "$builddir"
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
make install DESTDIR="$pkgdir" PREFIX="/usr" \
SHARE_DIR="$pkgdir/usr/share/zsh/plugins/$pkgname"
}
-sha512sums="dd0dcb772add597eb6f04e9958fb960688a5a2e316d51792d573fbfe1fd43e5a63c0de2242f87837818f27d732d8872576978c950640c1d1eea92b7b01ae84b4 zsh-syntax-highlighting-0.5.0.tar.gz"
+sha512sums="bb83f41336e9010aa78ee5adc9a216ee53f3b4347041d1b273083940d9db4d0e4acd960150b28c41f6e5e8d00b029f00fca6f9a46955892e4547a9f2345e3b85 zsh-syntax-highlighting-0.6.0.tar.gz"