summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/freeswitch/APKBUILD68
-rw-r--r--testing/freeswitch/freeswitch-1.0.3-libtool22-2.patch240
-rw-r--r--testing/freeswitch/freeswitch-1.0.3-parallel-build.patch11
-rw-r--r--testing/freeswitch/freeswitch.initd19
-rwxr-xr-xtesting/freeswitch/freeswitch.install15
-rw-r--r--testing/freeswitch/modules.conf75
6 files changed, 0 insertions, 428 deletions
diff --git a/testing/freeswitch/APKBUILD b/testing/freeswitch/APKBUILD
deleted file mode 100644
index df048f605ce..00000000000
--- a/testing/freeswitch/APKBUILD
+++ /dev/null
@@ -1,68 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-pkgname=freeswitch
-pkgver=1.0.3
-pkgrel=1
-pkgdesc="A communications platform written in C from the ground up"
-url="http://www.freeswitch.org"
-license="GPL"
-depends=""
-makedepends="uclibc++-dev curl-dev unixodbc-dev zlib-dev openssl-dev
- autoconf automake libtool"
-install=
-subpackages="$pkgname-dev"
-source="http://files.freeswitch.org/freeswitch-1.0.3.tar.gz
- modules.conf
- freeswitch-1.0.3-libtool22-2.patch
- freeswitch-1.0.3-parallel-build.patch
- "
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- for i in ../*.patch; do
- msg "Appling $i..."
- patch -p1 < $i || return 1
- done
- cp -f "$srcdir/modules.conf" modules.conf || return 1
-
- aclocal || return 1
- autoconf || return 1
- automake --add-missing || return 1
- autoheader || return 1
- libtoolize || return 1
-
- export CXX=g++-uc
- # i think our max cmd len is 32768
- # by specifying it here we save our selves from some CPU cycles
- export lt_cv_sys_max_cmd_len=8192
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc/freeswitch \
- --with-modinstdir=/usr/lib/freeswitch \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
-
- # check how/when parallel builds are fixed here:
- # http://jira.freeswitch.org/browse/FSBUILD-6
-
- # build the libs and prerequisites in parallel first
- make libs/apr/libapr-1.la \
- libs/apr-util/libaprutil-1.la \
- libs/speex/libspeex/libspeexdsp.la \
- libs/sqlite/libsqlite3.la \
- libs/pcre/libpcre.la \
- libs/srtp/libsrtp.la \
- src/include/switch_version.h
-
- # then the rest should build in parallel too
- make || return 1
- make -j1 DESTDIR="$pkgdir" install
-
- # TODO: make and test init.d scripts
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="9352e159b6067ce15afe50ba45c40df7 freeswitch-1.0.3.tar.gz
-c05f2356be159e99b3845f5260a33599 modules.conf
-c9dc93ce5cf13b4bc9ca620131709671 freeswitch-1.0.3-libtool22-2.patch
-5bd0c33cbd2a0a0ea4c12c0e1083e3a2 freeswitch-1.0.3-parallel-build.patch"
diff --git a/testing/freeswitch/freeswitch-1.0.3-libtool22-2.patch b/testing/freeswitch/freeswitch-1.0.3-libtool22-2.patch
deleted file mode 100644
index f36fa45f6e4..00000000000
--- a/testing/freeswitch/freeswitch-1.0.3-libtool22-2.patch
+++ /dev/null
@@ -1,240 +0,0 @@
-This is cooked version of:
-5. Text File fs-r11674-libtool22-2.patch (14 kB)
-http://jira.freeswitch.org/browse/FSBUILD-82
-
-Index: libs/apr/build/config.sub
-===================================================================
---- a/libs/apr/build/config.sub (revision 11675)
-+++ b/libs/apr/build/config.sub (working copy)
-@@ -1,10 +1,9 @@
- #! /bin/sh
- # Configuration validation subroutine script.
- # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
--# 2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
--# Inc.
-+# 2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
-
--timestamp='2006-07-02'
-+timestamp='2005-12-11'
-
- # This file is (in principle) common to ALL GNU software.
- # The presence of a machine in this file suggests that SOME GNU software
-@@ -241,7 +240,7 @@
- | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
- | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
- | am33_2.0 \
-- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
-+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
- | bfin \
- | c4x | clipper \
- | d10v | d30v | dlx | dsp16xx \
-@@ -249,8 +248,7 @@
- | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
- | i370 | i860 | i960 | ia64 \
- | ip2k | iq2000 \
-- | m32c | m32r | m32rle | m68000 | m68k | m88k \
-- | maxq | mb | microblaze | mcore \
-+ | m32r | m32rle | m68000 | m68k | m88k | maxq | mcore \
- | mips | mipsbe | mipseb | mipsel | mipsle \
- | mips16 \
- | mips64 | mips64el \
-@@ -270,17 +268,16 @@
- | mn10200 | mn10300 \
- | mt \
- | msp430 \
-- | nios | nios2 \
- | ns16k | ns32k \
- | or32 \
- | pdp10 | pdp11 | pj | pjl \
- | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
- | pyramid \
-- | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
-+ | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
- | sh64 | sh64le \
-- | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
-- | sparcv8 | sparcv9 | sparcv9b | sparcv9v \
-- | spu | strongarm \
-+ | sparc | sparc64 | sparc64b | sparc86x | sparclet | sparclite \
-+ | sparcv8 | sparcv9 | sparcv9b \
-+ | strongarm \
- | tahoe | thumb | tic4x | tic80 | tron \
- | v850 | v850e \
- | we32k \
-@@ -288,6 +285,9 @@
- | z8k)
- basic_machine=$basic_machine-unknown
- ;;
-+ m32c)
-+ basic_machine=$basic_machine-unknown
-+ ;;
- m6811 | m68hc11 | m6812 | m68hc12)
- # Motorola 68HC11/12.
- basic_machine=$basic_machine-unknown
-@@ -317,7 +317,7 @@
- | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
- | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
- | arm-* | armbe-* | armle-* | armeb-* | armv*-* \
-- | avr-* | avr32-* \
-+ | avr-* \
- | bfin-* | bs2000-* \
- | c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
- | clipper-* | craynv-* | cydra-* \
-@@ -328,7 +328,7 @@
- | hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
- | i*86-* | i860-* | i960-* | ia64-* \
- | ip2k-* | iq2000-* \
-- | m32c-* | m32r-* | m32rle-* \
-+ | m32r-* | m32rle-* \
- | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
- | m88110-* | m88k-* | maxq-* | mcore-* \
- | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
-@@ -350,18 +350,17 @@
- | mmix-* \
- | mt-* \
- | msp430-* \
-- | nios-* | nios2-* \
- | none-* | np1-* | ns16k-* | ns32k-* \
- | orion-* \
- | pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
- | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
- | pyramid-* \
- | romp-* | rs6000-* \
-- | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
-+ | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | shbe-* \
- | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
-- | sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
-+ | sparc-* | sparc64-* | sparc64b-* | sparc86x-* | sparclet-* \
- | sparclite-* \
-- | sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | strongarm-* | sv1-* | sx?-* \
-+ | sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
- | tahoe-* | thumb-* \
- | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
- | tron-* \
-@@ -372,6 +371,8 @@
- | ymp-* \
- | z8k-*)
- ;;
-+ m32c-*)
-+ ;;
- # Recognize the various machine names and aliases which stand
- # for a CPU type and a company and sometimes even an OS.
- 386bsd)
-@@ -817,12 +818,6 @@
- pc532 | pc532-*)
- basic_machine=ns32k-pc532
- ;;
-- pc98)
-- basic_machine=i386-pc
-- ;;
-- pc98-*)
-- basic_machine=i386-`echo $basic_machine | sed 's/^[^-]*-//'`
-- ;;
- pentium | p5 | k5 | k6 | nexgen | viac3)
- basic_machine=i586-pc
- ;;
-@@ -1125,7 +1120,7 @@
- sh[1234] | sh[24]a | sh[34]eb | sh[1234]le | sh[23]ele)
- basic_machine=sh-unknown
- ;;
-- sparc | sparcv8 | sparcv9 | sparcv9b | sparcv9v)
-+ sparc | sparcv8 | sparcv9 | sparcv9b)
- basic_machine=sparc-sun
- ;;
- cydra)
-@@ -1198,8 +1193,7 @@
- | -aos* \
- | -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
- | -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
-- | -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* \
-- | -openbsd* | -solidbsd* \
-+ | -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* | -openbsd* \
- | -ekkobsd* | -kfreebsd* | -freebsd* | -riscix* | -lynxos* \
- | -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
- | -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
-@@ -1214,7 +1208,7 @@
- | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
- | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
- | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
-- | -skyos* | -haiku* | -rdos* | -toppers*)
-+ | -skyos* | -haiku* | -rdos*)
- # Remember, each alternative MUST END IN *, to match a version number.
- ;;
- -qnx*)
-@@ -1366,9 +1360,6 @@
- # system, and we'll never get to this point.
-
- case $basic_machine in
-- spu-*)
-- os=-elf
-- ;;
- *-acorn)
- os=-riscix1.2
- ;;
-@@ -1378,9 +1369,9 @@
- arm*-semi)
- os=-aout
- ;;
-- c4x-* | tic4x-*)
-- os=-coff
-- ;;
-+ c4x-* | tic4x-*)
-+ os=-coff
-+ ;;
- # This must come before the *-dec entry.
- pdp10-*)
- os=-tops20
-Index: build/modmake.rules.in
-===================================================================
---- a/build/modmake.rules.in (revision 11675)
-+++ b/build/modmake.rules.in (working copy)
-@@ -10,7 +10,7 @@
- INSTALL=@INSTALL@
- GETLIB=@GETLIB@
- LIBTOOL=@LIBTOOL@
--LTINSTALL=$(LIBTOOL) --mode=install $(INSTALL)
-+LTINSTALL=$(LIBTOOL) --quiet --mode=install $(INSTALL)
- LTUNINSTALL=$(LIBTOOL) --mode=uninstall rm -f
- CCLD = $(CC)
- CXXLD = $(CXX)
-@@ -29,7 +29,8 @@
- DYLD_LIBRARY_PATH=@libdir@:$DYLD_LIBRARY_PATH
- LD_LIBRARY_PATH=@libdir@:$LD_LIBRARY_PATH
- OSARCH=`uname -s`
--DYNAMIC_LIB_EXTEN = @DYNAMIC_LIB_EXTEN@
-+DYNAMIC_LIB_EXTEN = la
-+#DYNAMIC_LIB_EXTEN = @DYNAMIC_LIB_EXTEN@
- SOLINK = @SOLINK@
-
- LDFLAGS=@SWITCH_AM_LDFLAGS@ @LDFLAGS@ $(OUR_LDFLAGS)
-@@ -39,11 +40,11 @@
-
- COMPILE = $(CC) $(ALL_CFLAGS) $(DEFS)
- LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(COMPILE)
--LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(ALL_CFLAGS) $(LDFLAGS) -o $@
-+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(ALL_CFLAGS) $(LDFLAGS) -shared -module -avoid-version -rpath $(MODINSTDIR) -o $@
-
- CXXCOMPILE = $(CXX) $(ALL_CXXFLAGS) $(DEFS)
- LTCXXCOMPILE = $(LIBTOOL) --mode=compile --tag=CXX $(CXXCOMPILE)
--CXXLINK = $(LIBTOOL) --mode=link --tag=CXX $(CXXLD) $(ALL_CXXFLAGS) $(LDFLAGS) -o $@
-+CXXLINK = $(LIBTOOL) --mode=link --tag=CXX $(CXXLD) $(ALL_CXXFLAGS) $(LDFLAGS) -shared -module -avoid-version -rpath $(MODINSTDIR) -o $@
-
- CSOURCEFILE=$(MODNAME).c
- CXXSOURCEFILE=$(MODNAME).cpp
-@@ -107,14 +108,14 @@
- exit 1 ;\
- fi
-
--$(MODNAME).$(DYNAMIC_LIB_EXTEN): $(LIBS) $(LOCAL_LIBADD) $(OUR_DEPS) $(LOCAL_OBJS) $(OUR_OBJS) $(SOURCEFILE) $(MODNAME).o
-+$(MODNAME).$(DYNAMIC_LIB_EXTEN): $(LIBS) $(LOCAL_LIBADD) $(OUR_DEPS) $(LOCAL_OBJS) $(OUR_OBJS) $(SOURCEFILE) $(MODNAME).lo
- @echo Creating $@...
- @test -d .libs || mkdir .libs
- @error="";\
- if test -f $(CSOURCEFILE); then \
-- $(LINK) $(SOLINK) $(MODNAME).o $(LIBS) $(LOCAL_LDFLAGS) $(LOCAL_OBJS) $(OUR_OBJS) $(LOCAL_LIBADD) $(LINK_OUTPUT_REDIR) ;\
-+ $(LINK) $(SOLINK) $(MODNAME).lo $(LIBS) $(LOCAL_LDFLAGS) $(LOCAL_OBJS) $(OUR_OBJS) $(LOCAL_LIBADD) $(LINK_OUTPUT_REDIR) ;\
- else \
-- $(CXXLINK) $(SOLINK) $(MODNAME).o $(LIBS) $(LOCAL_LDFLAGS) $(LOCAL_OBJS) $(OUR_OBJS) $(LOCAL_LIBADD) $(LINK_OUTPUT_REDIR) ;\
-+ $(CXXLINK) $(SOLINK) $(MODNAME).lo $(LIBS) $(LOCAL_LDFLAGS) $(LOCAL_OBJS) $(OUR_OBJS) $(LOCAL_LIBADD) $(LINK_OUTPUT_REDIR) ;\
- fi;
-
- mod_clean:
diff --git a/testing/freeswitch/freeswitch-1.0.3-parallel-build.patch b/testing/freeswitch/freeswitch-1.0.3-parallel-build.patch
deleted file mode 100644
index 1e95243931f..00000000000
--- a/testing/freeswitch/freeswitch-1.0.3-parallel-build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- freeswitch-1.0.3/build/modmake.rules.in.orig 2009-03-04 12:58:46.000000000 +0000
-+++ freeswitch-1.0.3/build/modmake.rules.in 2009-03-04 12:59:10.000000000 +0000
-@@ -57,7 +57,7 @@
- RECURSE_OUR_DEPS=`test -z "$(WANT_CURL)" || if test ! -z "$(LIBCURL_DEPS)"; then echo $(CURLLA); fi `
- RECURSE_OUR_CFLAGS=`test -z "$(WANT_CURL)" || echo $(LIBCURL_CPPFLAGS) ; $(LOCAL_INSERT_CFLAGS) `
- RECURSE_OUR_LDFLAGS=`test -z "$(WANT_CURL)" || echo $(LIBCURL) ; $(LOCAL_INSERT_LDFLAGS) `
--RECURSE_MAKE=modname="$(RECURSE_MODNAME)" ; \
-+RECURSE_MAKE=+modname="$(RECURSE_MODNAME)" ; \
- sourcefile="$(RECURSE_SOURCEFILE)" ; \
- osarch=`uname -s` ; \
- ourdefs="$(RECURSE_OUR_DEPS)" ; \
diff --git a/testing/freeswitch/freeswitch.initd b/testing/freeswitch/freeswitch.initd
deleted file mode 100644
index 34f44139069..00000000000
--- a/testing/freeswitch/freeswitch.initd
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/sbin/runscript
-
-NAME=freeswitch
-USER=freeswitch
-DAEMON=/usr/bin/freeswitch
-OPTIONS_START="-u $USER -g $GROUP -nc"
-OPTIONS_STOP="-stop"
-
-start() {
- ebegin "Starting $NAME"
- $DAEMON $OPTIONS_START
- eend 0
- }
-
-stop() {
- ebegin "Stopping $NAME"
- $DAEMON $OPTIONS_STOP
- eend 0
- }
diff --git a/testing/freeswitch/freeswitch.install b/testing/freeswitch/freeswitch.install
deleted file mode 100755
index 0507fe532f8..00000000000
--- a/testing/freeswitch/freeswitch.install
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- pre_install)
- adduser -h /dev/null -s /bin/false -D freeswitch 2>/dev/null
- ;;
- post_install)
- chown -R freeswitch:freeswitch /etc/freeswitch/
- ;;
- post_deinstall)
- deluser freeswitch
- delgroup freeswitch
- ;;
-esac
-
diff --git a/testing/freeswitch/modules.conf b/testing/freeswitch/modules.conf
deleted file mode 100644
index c6f5a05de83..00000000000
--- a/testing/freeswitch/modules.conf
+++ /dev/null
@@ -1,75 +0,0 @@
-loggers/mod_console
-loggers/mod_logfile
-loggers/mod_syslog
-applications/mod_commands
-applications/mod_conference
-applications/mod_dptools
-applications/mod_enum
-applications/mod_fifo
-#applications/mod_fax
-applications/mod_voicemail
-#applications/mod_lcr
-applications/mod_limit
-applications/mod_expr
-applications/mod_esf
-#applications/mod_easyroute
-applications/mod_fsv
-#applications/mod_soundtouch
-#applications/mod_rss
-#applications/mod_snom
-#applications/mod_vmd
-#asr_tts/mod_flite
-#asr_tts/mod_pocketsphinx
-#asr_tts/mod_cepstral
-codecs/mod_g723_1
-codecs/mod_amr
-#codecs/mod_amrwb
-codecs/mod_g729
-codecs/mod_h26x
-codecs/mod_voipcodecs
-codecs/mod_ilbc
-codecs/mod_speex
-#codecs/mod_siren
-#codecs/mod_celt
-#codecs/mod_dahdi_codec
-#dialplans/mod_dialplan_directory
-dialplans/mod_dialplan_xml
-dialplans/mod_dialplan_asterisk
-#directories/mod_ldap
-#endpoints/mod_dingaling
-endpoints/mod_iax
-#endpoints/mod_portaudio
-endpoints/mod_sofia
-endpoints/mod_loopback
-#endpoints/mod_alsa
-#endpoints/mod_opal
-#../../libs/openzap/mod_openzap
-#event_handlers/mod_event_multicast
-event_handlers/mod_event_socket
-event_handlers/mod_cdr_csv
-#event_handlers/mod_radius_cdr
-formats/mod_native_file
-formats/mod_sndfile
-#formats/mod_shout
-formats/mod_local_stream
-formats/mod_tone_stream
-#languages/mod_python
-#languages/mod_spidermonkey
-#languages/mod_spidermonkey_teletone
-#languages/mod_spidermonkey_core_db
-#languages/mod_spidermonkey_socket
-#languages/mod_spidermonkey_odbc
-languages/mod_lua
-#languages/mod_perl
-#languages/mod_yaml
-#xml_int/mod_xml_rpc
-#xml_int/mod_xml_curl
-#xml_int/mod_xml_cdr
-#xml_int/mod_xml_ldap
-say/mod_say_en
-#say/mod_say_de
-#say/mod_say_es
-#say/mod_say_fr
-#say/mod_say_it
-#say/mod_say_nl
-#say/mod_say_zh