aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/ytnef/APKBUILD44
-rw-r--r--testing/ytnef/ytnef-pkgconfig.patch9
-rw-r--r--testing/ytnef/ytnef/APKBUILD26
3 files changed, 79 insertions, 0 deletions
diff --git a/testing/ytnef/APKBUILD b/testing/ytnef/APKBUILD
new file mode 100644
index 00000000000..696ac8ee6b8
--- /dev/null
+++ b/testing/ytnef/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ytnef
+pkgver=1.9.2
+pkgrel=0
+pkgdesc="TNEF Stream Reader - for winmail.dat files"
+url="https://github.com/Yeraze/ytnef"
+arch="all"
+license="GPL+"
+depends=""
+makedepends="autoconf automake libtool file"
+install=""
+subpackages="$pkgname-dev $pkgname-libs"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Yeraze/ytnef/archive/v$pkgver.tar.gz
+ ytnef-pkgconfig.patch
+ "
+builddir="$srcdir"/ytnef-$pkgver
+
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" includedir=/usr/include/libytnef
+}
+
+sha512sums="125727a8afac959ac9c60fa977913da743b1ace05ea6af6cd75fff3a786ecf7cb54b49006c8c5249eb48d9aefe0ffcdc24af2944a8611f54a03eb4c24a78506e ytnef-1.9.2.tar.gz
+bf829bd56fff81f30ad32da4714677224b537cf38fb084afe73fd2d5723f73741e0423149832d9f61c0e368781040fd29e66f22c1c6c099d6d300f0649d6ba47 ytnef-pkgconfig.patch"
diff --git a/testing/ytnef/ytnef-pkgconfig.patch b/testing/ytnef/ytnef-pkgconfig.patch
new file mode 100644
index 00000000000..92d13a2b8be
--- /dev/null
+++ b/testing/ytnef/ytnef-pkgconfig.patch
@@ -0,0 +1,9 @@
+diff -up ytnef-1.9.2/lib/libytnef.pc.in.orig ytnef-1.9.2/lib/libytnef.pc.in
+--- ytnef-1.9.2/lib/libytnef.pc.in.orig 2017-03-28 10:50:58.496400854 +0200
++++ ytnef-1.9.2/lib/libytnef.pc.in 2017-03-28 10:51:20.576558722 +0200
+@@ -8,4 +8,4 @@ Description: Yerase's TNEF Stream Reader
+ URL: https://github.com/Yeraze/ytnef
+ Version: @VERSION@
+ Libs: -L${libdir} -lytnef
+-Cflags: -I${includedir}
++Cflags: -I${includedir}/libytnef
diff --git a/testing/ytnef/ytnef/APKBUILD b/testing/ytnef/ytnef/APKBUILD
new file mode 100644
index 00000000000..6b15208708d
--- /dev/null
+++ b/testing/ytnef/ytnef/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=ytnef
+pkgver=1.9.2
+pkgrel=0
+pkgdesc=""
+url=""
+arch="all"
+license=""
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="ytnef-$pkgver.tar.gz::https://github.com/Yeraze/ytnef/archive/v$pkgver.tar.gz"
+builddir="$srcdir/ytnef-$pkgver"
+
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+}
+
+sha512sums="125727a8afac959ac9c60fa977913da743b1ace05ea6af6cd75fff3a786ecf7cb54b49006c8c5249eb48d9aefe0ffcdc24af2944a8611f54a03eb4c24a78506e ytnef-1.9.2.tar.gz"