aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-db_file-lock/APKBUILD42
-rw-r--r--testing/perl-db_file-lock/fix-bug-98224-test-fails.patch16
2 files changed, 58 insertions, 0 deletions
diff --git a/testing/perl-db_file-lock/APKBUILD b/testing/perl-db_file-lock/APKBUILD
new file mode 100644
index 00000000000..65576d532c5
--- /dev/null
+++ b/testing/perl-db_file-lock/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-db_file-lock
+_pkgreal=DB_File-Lock
+pkgver=0.05
+pkgrel=0
+pkgdesc="DB_File::Lock - Locking with flock wrapper for DB_File"
+url="https://metacpan.org/release/DB_File-Lock/"
+arch="noarch"
+license="GPL PerlArtistic"
+depends="perl-db_file"
+makedepends="perl-dev perl-db_file"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DH/DHARRIS/DB_File-Lock-0.05.tar.gz
+ fix-bug-98224-test-fails.patch"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare
+
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="e57dec372a598df004faa99438f0ef9e3c7d73d86e2638573c6e7c09116f748a5cf3fd85fc911999f37cfe51f77a11081cb8ae1353a3061e4cbdbb7a7bb3de07 DB_File-Lock-0.05.tar.gz
+194820b3520f44c9701642dcd5920e3e24cb7b42d50ee228c6a51e66371b1985021a3c7d607ef5e15da1e5f6587f7d56c4b4b76bf9688b9523e36336aba02295 fix-bug-98224-test-fails.patch"
diff --git a/testing/perl-db_file-lock/fix-bug-98224-test-fails.patch b/testing/perl-db_file-lock/fix-bug-98224-test-fails.patch
new file mode 100644
index 00000000000..40a9adf9b2e
--- /dev/null
+++ b/testing/perl-db_file-lock/fix-bug-98224-test-fails.patch
@@ -0,0 +1,16 @@
+diff --git a/test.pl b/test.pl
+old mode 100644
+new mode 100755
+index 92ebcf6..cba6da6
+--- a/test.pl
++++ b/test.pl
+@@ -81,7 +81,7 @@ if ( not defined $pid ) {
+ sleep(1);
+ $TEST_NUM += 2;
+ report_result( not tie %hash3, 'DB_File::Lock', $file1, O_RDWR, 0600, $DB_HASH, $nonblock_write );
+- report_result( not defined %hash3 ); # double check and satisfy -w about %hash3
++ report_result( not keys %hash3 ); # double check and satisfy -w about %hash3
+ $TEST_NUM += 1;
+ report_result( wait() == $pid );
+ report_result( tie %hash3, 'DB_File::Lock', $file1, O_RDWR, 0600, $DB_HASH, $nonblock_write );
+--