aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/blender/0001-musl-fixes.patch8
-rw-r--r--testing/blender/0002-fix-linking-issue.patch4
-rw-r--r--testing/blender/0003-increase-thread-stack-size-for-musl.patch4
-rw-r--r--testing/blender/APKBUILD20
4 files changed, 20 insertions, 16 deletions
diff --git a/testing/blender/0001-musl-fixes.patch b/testing/blender/0001-musl-fixes.patch
index a2c7f72b348..8ca03d433ce 100644
--- a/testing/blender/0001-musl-fixes.patch
+++ b/testing/blender/0001-musl-fixes.patch
@@ -1,4 +1,4 @@
-From e530dc5b32695c208aa46bfe460ac7d76159a6d3 Mon Sep 17 00:00:00 2001
+From 9f5cd19b34c6357d0473f61b8b4d13b28c3e8b6c Mon Sep 17 00:00:00 2001
From: Leon Marz <lmarz@cs.uni-frankfurt.de>
Date: Wed, 25 Nov 2020 10:10:41 +0100
Subject: [PATCH 1/3] musl fixes
@@ -44,7 +44,7 @@ index 78e387e..d21c281 100644
-# endif /* __GLIBC_PREREQ */
#endif /* __linux__ */
diff --git a/source/blender/blenlib/intern/system.c b/source/blender/blenlib/intern/system.c
-index 8e3d489..4d0789b 100644
+index f4110c6..f5a32c5 100644
--- a/source/blender/blenlib/intern/system.c
+++ b/source/blender/blenlib/intern/system.c
@@ -35,7 +35,9 @@
@@ -67,7 +67,7 @@ index 8e3d489..4d0789b 100644
# define SIZE 100
void *buffer[SIZE];
diff --git a/source/blender/gpu/GPU_vertex_buffer.h b/source/blender/gpu/GPU_vertex_buffer.h
-index eeaebd3..93a77a2 100644
+index aae58de..0a3a627 100644
--- a/source/blender/gpu/GPU_vertex_buffer.h
+++ b/source/blender/gpu/GPU_vertex_buffer.h
@@ -118,7 +118,6 @@ GPU_INLINE void *GPU_vertbuf_raw_step(GPUVertBufRaw *a)
@@ -92,5 +92,5 @@ index 29e12a9..d90da8f 100644
# endif /* defined(__linux__) && defined(__GNUC__) */
# if defined(OSX_SSE_FPE)
--
-2.30.1
+2.31.1
diff --git a/testing/blender/0002-fix-linking-issue.patch b/testing/blender/0002-fix-linking-issue.patch
index 552938cb549..2eac80f9e58 100644
--- a/testing/blender/0002-fix-linking-issue.patch
+++ b/testing/blender/0002-fix-linking-issue.patch
@@ -1,4 +1,4 @@
-From 54f5929131f537b6cbb74b5a7da45858cef6020b Mon Sep 17 00:00:00 2001
+From 38035cf0b6f9a8af1938930d151973687d4ba561 Mon Sep 17 00:00:00 2001
From: Leon Marz <lmarz@cs.uni-frankfurt.de>
Date: Tue, 1 Sep 2020 09:11:18 +0200
Subject: [PATCH 2/3] fix linking issue
@@ -19,5 +19,5 @@ index 1739659..d6b442b 100644
+list(APPEND LIB "-lX11" "-lXi" "-lXxf86vm" "-lXfixes" "-lXrender")
blender_add_lib(bf_intern_ghost "${SRC}" "${INC}" "${INC_SYS}" "${LIB}")
--
-2.30.1
+2.31.1
diff --git a/testing/blender/0003-increase-thread-stack-size-for-musl.patch b/testing/blender/0003-increase-thread-stack-size-for-musl.patch
index c09ad05e887..8ff94b94638 100644
--- a/testing/blender/0003-increase-thread-stack-size-for-musl.patch
+++ b/testing/blender/0003-increase-thread-stack-size-for-musl.patch
@@ -1,4 +1,4 @@
-From 3c99b60fddf616268347b3569fea480076c00bef Mon Sep 17 00:00:00 2001
+From 7c5e611332e97d1678e4c32de84ad3dad1cc81a7 Mon Sep 17 00:00:00 2001
From: Damian Kurek <starfire24680@gmail.com>
Date: Sun, 22 Nov 2020 02:03:11 +0100
Subject: [PATCH 3/3] increase thread stack size for musl
@@ -44,5 +44,5 @@ index 29f9bec..58a63ce 100644
#else
std::thread std_thread;
--
-2.30.1
+2.31.1
diff --git a/testing/blender/APKBUILD b/testing/blender/APKBUILD
index deaec0e54e1..84201d509cf 100644
--- a/testing/blender/APKBUILD
+++ b/testing/blender/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Mark Riedesel <mark@klowner.com>
-# Contributor: Leon Marz <lmarz@cs.uni-frankfurt.de>
-# Maintainer: Mark Riedesel <mark@klowner.com>
+# Contributor: Leon Marz <main@lmarz.org>
+# Maintainer: Leon Marz <main@lmarz.org>
pkgname=blender
-pkgver=2.92.0
+pkgver=2.93.0
_pkgver=${pkgver%.[0-9]}
-pkgrel=3
+pkgrel=0
pkgdesc="3D Creation/Animation/Publishing System"
url="https://www.blender.org/"
arch="x86_64" # only on x86_64, mainly because of openvdb
@@ -23,6 +23,7 @@ makedepends="cmake
glew-dev
gmp-dev
jack-dev
+ libharu-dev
libjpeg-turbo-dev
libpng-dev
libsndfile-dev
@@ -44,6 +45,7 @@ makedepends="cmake
osl-dev
potrace-dev
pugixml-dev
+ pulseaudio-dev
py3-numpy-dev
python3-dev
sdl2-dev
@@ -136,7 +138,9 @@ python() {
ln -s /usr/share/blender/"$_pkgver" "$subpkgdir"/usr/lib/python"$_py_version"/site-packages/"$_pkgver"
}
-sha512sums="a2116a2b9d86d938c00b50ffdd93e561a29462e589db73361e7e0d43468ae0eb7c09337b832d70e29e0146d5a4ac40a9a20b0c7ca944faddb4187007ccca853f blender-2.92.0.tar.xz
-5c3c46c301cfbf9ba50ce8e2c6d1a96e85389db3fe74ddccf4150a6247312ca4b483c2bc46e540fb84b56c4cc529c4bec12ceb03ed163fd76cfa04c5fd1c748b 0001-musl-fixes.patch
-62dad98f6750d4f145a6b9f15c60d44e571d0b5a09f4ab71e5087b2ce546ba948195d3bdbd322f5da2222b0a89c81418d1ce3f0073aaf4da1e643ffc668b5b2f 0002-fix-linking-issue.patch
-43b793ef26e0ea066c39020762439ad31aaf3d9ccb9e7836dc6f46c6a1ca89f9ba0eefeaa458a7eec5ebd9702170b1682fa1343ad7bd5cf1cc49cc921a297888 0003-increase-thread-stack-size-for-musl.patch"
+sha512sums="
+660962e5368c8ff52ed095aba97d63c22aa8e2fdcb2042b1299b6d6edeb7eb1f702a9ee95ee7e47824681f9f48b971d2e32ec32cc6264165a4196b5f36c4a66d blender-2.93.0.tar.xz
+9a26ddc83d03fb24a03d567d134a30425b84d290e2d36f7bf4d5644b1d0a78a46f44c512550c1663d4c5ed5a316763446ff2da4cae2c63822f33f354fb7e6a05 0001-musl-fixes.patch
+aa3ac2d938e7182fde2ee9219f55c02f1447781f679a28b651f377f0b27f885a063b5bcbe6f8bafd80e4259b0f1e8e21c08cef05d54930b4aa828b818e1d1cee 0002-fix-linking-issue.patch
+8b305ad69ead11b12f08bfd55796cdb4560d04953ac2817d687c599a2179f7525a74a86f7b3d292832b002cf4075c7e1e7e2c164bb71ad977b917ec850e756f7 0003-increase-thread-stack-size-for-musl.patch
+"