aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/scummvm/APKBUILD12
-rw-r--r--testing/scummvm/disable-forbidden.patch22
2 files changed, 16 insertions, 18 deletions
diff --git a/testing/scummvm/APKBUILD b/testing/scummvm/APKBUILD
index 5af21c0e76f..99663c6c273 100644
--- a/testing/scummvm/APKBUILD
+++ b/testing/scummvm/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Thomas Kienlen <kommander@laposte.net>
# Maintainer: Thomas Kienlen <kommander@laposte.net>
pkgname=scummvm
-pkgver=2.2.0
-pkgrel=1
+pkgver=2.5.0
+pkgrel=0
pkgdesc="Engine for several graphical adventure games"
url="https://www.scummvm.org/"
arch="all"
@@ -26,8 +26,6 @@ subpackages="$pkgname-doc"
source="
https://downloads.scummvm.org/frs/scummvm/$pkgver/scummvm-$pkgver.tar.gz
disable-forbidden.patch
- 0001-FLUIDSYNTH-Simplify-FluidSynth-version-check.patch
- 0002-FLUIDSYNTH-Fix-compilation-with-Fluidsynth-2.2.patch
"
build() {
@@ -44,8 +42,6 @@ package() {
}
sha512sums="
-53128f59d59bdb1e9cad81c8b33da311ec7e6267a142fc44fd8ebe298c3b341b0f98e03346b47fe08f8fa0d98016b80d3b4a233a6dd9f608b756f8c09160fc94 scummvm-2.2.0.tar.gz
-92e22cc65454ad29dc580b03859cf7b78fdea5614eb370dbad05460bc6aac187b4be99213912ee58c7b9a7d1488bc02b7853337465bbc8c2405f5e4aefadf0f2 disable-forbidden.patch
-bc7bf322eed6fa1479b34a17f0db7f301ed66c6a1aaa81be3833fd317b39a001687b0d91bf572661e632c6234d633add0e545626c6e2bfac5b4e6135068c8106 0001-FLUIDSYNTH-Simplify-FluidSynth-version-check.patch
-fcb3621dc811aeab4ff2d4a5969c9e49991b65ac67cd2dbe0b3e436185ceaface2ed2644b6cce2fa2e37618b8d45849514797009e84bdce3e7c09325a8f9c257 0002-FLUIDSYNTH-Fix-compilation-with-Fluidsynth-2.2.patch
+112805850d8046a72bcdad8552a27d51e3d440fc56f7eb1fd2adfdd8b1c09a11d4697b69689b58efc0f4b676ed279e94900c37fe31017d39d29885f98bd94f97 scummvm-2.5.0.tar.gz
+a44de9540f18893b49b02c083694f8eb974e8ddead6d0c6b0453760d7452367cfcc4613215fab2223da8859ce389a53dd2f110cf3389798761c95efafd886542 disable-forbidden.patch
"
diff --git a/testing/scummvm/disable-forbidden.patch b/testing/scummvm/disable-forbidden.patch
index 1d37efc2793..c44d94b3358 100644
--- a/testing/scummvm/disable-forbidden.patch
+++ b/testing/scummvm/disable-forbidden.patch
@@ -2,13 +2,15 @@ This patch fix compatibility between scummvm/forbidden security enforcement
and fortify-headers. The first is meant to avoid direct access to system
calls for scummvm to be fully portable on a lot of platforms.
---- a/common/scummsys.h
-+++ b/common/scummsys.h
-@@ -464,6 +464,4 @@
-
- #endif
-
--#include "common/forbidden.h"
--
- #endif
-
+--- a/common/forbidden.h
++++ b/common/forbidden.h
+@@ -39,6 +39,9 @@
+ * measure. Especially new code should avoid this at all costs.
+ */
+
++// Disable symbol overrides so that we can use system headers.
++#define FORBIDDEN_SYMBOL_ALLOW_ALL
++
+ #ifndef FORBIDDEN_SYMBOL_ALLOW_ALL
+
+ // Make sure scummsys.h is always included first