aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/j4-dmenu-desktop/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/testing/j4-dmenu-desktop/APKBUILD b/testing/j4-dmenu-desktop/APKBUILD
index d30e13c8ae2..a0f2788780f 100644
--- a/testing/j4-dmenu-desktop/APKBUILD
+++ b/testing/j4-dmenu-desktop/APKBUILD
@@ -1,16 +1,15 @@
# Maintainer: Bradley Saulteaux <bradsoto@gmail.com>
pkgname=j4-dmenu-desktop
-pkgver=2.16
+pkgver=2.17
pkgrel=0
pkgdesc="A fast desktop menu"
-url="https://github.com/enkore/${pkgname}"
+options="!check" # Requires a desktop-style system layout not present in builders
+url="https://github.com/enkore/$pkgname"
arch="all"
license="GPL-3.0-only"
depends="dmenu"
makedepends="cmake git"
-install=""
-subpackages=""
-source="${pkgname}-${pkgver}.tar.gz::${url}/archive/r${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::$url/archive/r$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-r$pkgver
build() {
@@ -19,6 +18,7 @@ build() {
}
check() {
+ # Test depends on /usr/share/applications existing on the system
make test
}
@@ -26,4 +26,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="d5bb0902d4bdc474fa20bc9d8f79de90a92bb4941f0d325dfcfaa1347ea3ad355b87da8194bc3f654970e9ab8848e6ecb5093f3c75fbaa8dbc40199fe6ea2837 j4-dmenu-desktop-2.16.tar.gz"
+sha512sums="7a41bb60a6b3afa7bf6229f08674d5f31e0152d0788a17edc210986d1b1f0d4fad13ffaa13c58ed7a0c5d2e67f8f95bb2a0f6556aeb0f2cc24c7d885b346325e j4-dmenu-desktop-2.17.tar.gz"