aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py-blessings/APKBUILD30
1 files changed, 25 insertions, 5 deletions
diff --git a/testing/py-blessings/APKBUILD b/testing/py-blessings/APKBUILD
index 3b5c5b85986..864f077ce5d 100644
--- a/testing/py-blessings/APKBUILD
+++ b/testing/py-blessings/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py-blessings
_pkgname=blessings
pkgver=1.7
-pkgrel=0
-pkgdesc="A Python wrapper around terminal coloring, styling and positioning"
+pkgrel=1
+pkgdesc="Wrapper around terminal coloring, styling and positioning"
url="https://github.com/erikrose/blessings"
arch="noarch"
license="MIT"
-depends="python2"
-makedepends="python2-dev py-setuptools"
+depends=""
+makedepends="py-setuptools python2-dev python3-dev"
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -17,11 +18,30 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
python2 setup.py build
+ python3 setup.py build
}
package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
sha512sums="66a8e7af6a8807c8be68f4d71db25ca6c26f46ddfa9a7e4792a2f73033df81d8392633ff75e6fa131039d9136030844ed93b11316b9f7e2e6ea77675f2f3e528 blessings-1.7.tar.gz"