aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/file-roller/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/file-roller/APKBUILD b/testing/file-roller/APKBUILD
new file mode 100644
index 00000000000..6869f8c86ba
--- /dev/null
+++ b/testing/file-roller/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=file-roller
+pkgver=3.32.1
+pkgrel=0
+pkgdesc="File Roller is an archive manager for the GNOME desktop "
+url="https://wiki.gnome.org/Apps/FileRoller"
+arch="all"
+license="GPL-2.0-or-later"
+depends="cpio"
+makedepends="meson glib-dev gtk+3.0-dev json-glib-dev libnotify-dev libarchive-dev
+ itstool"
+subpackages="$pkgname-lang"
+source="https://download.gnome.org/sources/file-roller/${pkgver%.*}/file-roller-${pkgver}.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dpackagekit=false \
+ -Dcpio=/usr/bin/cpio \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="a92bc12aa1c2545125c51a106605ad0d10256b990ed1cc40faff66440415a97bb2b6290de4b1ab484c38d33ee940d399e983c340b7a446eacb9489be6f764a36 file-roller-3.32.1.tar.xz"