aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/log4cplus/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/testing/log4cplus/APKBUILD b/testing/log4cplus/APKBUILD
index ff439b2d5a6..c20d5a1f2ab 100644
--- a/testing/log4cplus/APKBUILD
+++ b/testing/log4cplus/APKBUILD
@@ -12,6 +12,7 @@ arch="all"
license="Apache-2.0"
depends=""
depends_dev=""
+checkdepends="findutils"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
@@ -32,9 +33,15 @@ build() {
make
}
+_cat_found_file() {
+ local _rc="$?"
+ find -name "$1" -type f -ls -printf '%P {{{\n' -exec cat -v -n '{}' ';' -printf '}}} %P\n'
+ return "$_rc"
+}
+
check() {
cd "$builddir"
- make check
+ make check || _cat_found_file testsuite.log
}
package() {