aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/apache2-mod-perl/APKBUILD15
-rw-r--r--testing/apache2-mod-perl/mod_perl-2.0.5-nolfs.patch14
2 files changed, 27 insertions, 2 deletions
diff --git a/testing/apache2-mod-perl/APKBUILD b/testing/apache2-mod-perl/APKBUILD
index 40d3a543803..badafd0efdc 100644
--- a/testing/apache2-mod-perl/APKBUILD
+++ b/testing/apache2-mod-perl/APKBUILD
@@ -3,7 +3,7 @@
pkgname=apache2-mod-perl
_realname=mod_perl
pkgver=2.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Perl Module for Apache2"
url="http://perl.apache.org/"
arch="all"
@@ -15,9 +15,19 @@ install="$pkgname.post-install"
subpackages="$pkgname-doc $pkgname-dev"
source="http://search.cpan.org/CPAN/authors/id/P/PH/PHRED/${_realname}-${pkgver}.tar.gz
$pkgname.apache2.conf
+ mod_perl-2.0.5-nolfs.patch
"
_builddir="$srcdir"/${_realname}-${pkgver}
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor \
@@ -55,4 +65,5 @@ doc() {
}
md5sums="03d01d135a122bd8cebd0cd5b185d674 mod_perl-2.0.5.tar.gz
-86b84bb56b49a95772a7f773fc019043 apache2-mod-perl.apache2.conf"
+86b84bb56b49a95772a7f773fc019043 apache2-mod-perl.apache2.conf
+088e082afef57f92f234a01269e24ce5 mod_perl-2.0.5-nolfs.patch"
diff --git a/testing/apache2-mod-perl/mod_perl-2.0.5-nolfs.patch b/testing/apache2-mod-perl/mod_perl-2.0.5-nolfs.patch
new file mode 100644
index 00000000000..3eb345b6651
--- /dev/null
+++ b/testing/apache2-mod-perl/mod_perl-2.0.5-nolfs.patch
@@ -0,0 +1,14 @@
+Index: mod_perl-2.0.5/lib/Apache2/Build.pm
+===================================================================
+--- mod_perl-2.0.5.orig/lib/Apache2/Build.pm 2011-02-02 21:23:47.000000000 +0100
++++ mod_perl-2.0.5/lib/Apache2/Build.pm 2011-05-26 17:12:46.276946520 +0200
+@@ -2147,7 +2147,8 @@ sub has_large_files_conflict {
+ # with it is that we didn't have such a case yet, but may need to
+ # deal with it later
+
+- return $perl_lfs64 ^ $apr_lfs64;
++ return 0;
++ # $perl_lfs64 ^ $apr_lfs64;
+ }
+
+ # if perl is built with uselargefiles, but apr not, the build won't