aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/kfloppy/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/kfloppy/APKBUILD b/testing/kfloppy/APKBUILD
new file mode 100644
index 00000000000..3f2c46b79d0
--- /dev/null
+++ b/testing/kfloppy/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kfloppy
+pkgver=19.04.3
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/utilities/org.kde.kfloppy"
+pkgdesc="A utility that provides a straightforward graphical means to format 3.5\" and 5.25\" floppy disks"
+license="GPL-2.0-or-later"
+depends="dosfstools e2fsprogs coreutils"
+makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev kcoreaddons-dev kcompletion-dev kdoctools-dev kxmlgui-dev kcrash-dev kconfig-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="59a466b82321d021343446c8a7e8c2e6479c1fe74644dd008cf65c44cd0ab7ce414a6d377c73299949b7f32d2341895a8b8c62fa5a1aeff707d44995284e26bc kfloppy-19.04.3.tar.xz"