aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/dep/APKBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/testing/dep/APKBUILD b/testing/dep/APKBUILD
index 5440620740c..eb6f81e564a 100644
--- a/testing/dep/APKBUILD
+++ b/testing/dep/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ed Robinson <edward-robinson@cookpad.com>
# Maintainer: Ed Robinson <edward-robinson@cookpad.com>
pkgname=dep
-pkgver=0.3.2
+pkgver=0.4.1
pkgrel=0
pkgdesc="Go dependency management tool"
url="https://github.com/golang/dep"
@@ -10,33 +10,29 @@ license="BSD-3-Clause"
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/golang/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
-subpackages=$pkgname-doc
+
+builddir="$srcdir/src/github.com/golang/$pkgname"
prepare() {
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
default_prepare
- export GOPATH="$(pwd)/_gopath"
- _golang="${GOPATH}/src/github.com/golang"
- mkdir -vp ${_golang}
- ln -vsf ${builddir} ${_golang}/${pkgname}
}
build() {
- go build github.com/golang/dep/cmd/dep
-}
-
-package() {
+ export GOPATH="$srcdir"
cd "$builddir"
- install -Dm755 dep "$pkgdir"/usr/bin/dep
+ go build -ldflags="-X main.version=$pkgver" -o ./bin/dep ./cmd/dep
}
-doc () {
+package() {
cd "$builddir"
- install -Dm644 LICENSE "$subpkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 ./bin/dep "$pkgdir"/usr/bin/dep
}
check() {
- cd "$GOPATH"/src/github.com/golang/${pkgname}
- ./dep status
+ cd "$builddir"
+ ./bin/dep status > /dev/null
}
-sha512sums="3fae14328904bda9de06edd2a2614711c4f44d6a70b21210ca7bd00059c66810697a18892e7932274916befb2468d8756be97648e0912c72700b4100c3e16f7b dep-0.3.2.tar.gz"
+sha512sums="29caef5dbbb21020f4ba4024b9c8601da5c7f9f8caa5ab63c6dfa927be2140d33037473600246f35a6e58f94bad592b1974c38b8b9fec6f4d1d68ec8324db3d2 dep-0.4.1.tar.gz"