aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py-tqdm/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/py-tqdm/APKBUILD b/testing/py-tqdm/APKBUILD
index fa17b67bbc4..819b4253254 100644
--- a/testing/py-tqdm/APKBUILD
+++ b/testing/py-tqdm/APKBUILD
@@ -2,7 +2,7 @@
pkgname=py-tqdm
_pkgname=tqdm
pkgver=4.19.5
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, Extensible Progress Meter"
url="https://pypi.python.org/pypi/tqdm"
arch="noarch"
@@ -39,17 +39,26 @@ check() {
}
package() {
- mkdir -p "$pkgdir"
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s tqdm-3 "$pkgdir"/usr/bin/tqdm
}
_py() {
local python="$1"
+ local pyver="${python:6:1}"
pkgdesc="$pkgdesc ($python)"
depends="$python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
+
+ cd "$subpkgdir"
+
+ # Add version suffix to executable.
+ mv usr/bin/tqdm usr/bin/tqdm-$pyver
+
+ rm -r usr/man
}
_py2() {