aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py-shortuuid/APKBUILD46
-rw-r--r--testing/py3-shortuuid/APKBUILD26
2 files changed, 26 insertions, 46 deletions
diff --git a/testing/py-shortuuid/APKBUILD b/testing/py-shortuuid/APKBUILD
deleted file mode 100644
index 732bc31179c..00000000000
--- a/testing/py-shortuuid/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer:
-pkgname=py-shortuuid
-pkgver=0.5.0
-pkgrel=1
-pkgdesc="an shortuuid implementation"
-url="https://pypi.python.org/pypi/shortuuid/"
-arch="noarch"
-license="BSD"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-shortuuid:py2 py3-shortuuid:py3"
-source="https://files.pythonhosted.org/packages/source/s/shortuuid/shortuuid-$pkgver.tar.gz"
-builddir="$srcdir/shortuuid-$pkgver"
-
-build() {
- cd "$_builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ${python#python}"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-py2() {
- cd "$builddir"
- _py python2
-}
-
-py3() {
- cd "$builddir"
- _py python3
-}
-
-sha512sums="bf0b804281af1a515979a104c22e0c0e5cf99fe55efe6e29bb4b4b0d1d5a78b1e83a2d0262d6c2e2c2745f5ea198153fba80718aabac2955c691e6cb9bd5f4b5 shortuuid-0.5.0.tar.gz"
diff --git a/testing/py3-shortuuid/APKBUILD b/testing/py3-shortuuid/APKBUILD
new file mode 100644
index 00000000000..933dbbdc183
--- /dev/null
+++ b/testing/py3-shortuuid/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer:
+pkgname=py3-shortuuid
+_pkgname=shortuuid
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Python library that generates short, pretty, unambiguous unique IDs"
+url="https://pypi.python.org/pypi/shortuuid/"
+arch="noarch"
+license="BSD"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/shortuuid-$pkgver"
+
+replaces="py-shortuuid" # Backwards compatibility
+provides="py-shortuuid=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="bf0b804281af1a515979a104c22e0c0e5cf99fe55efe6e29bb4b4b0d1d5a78b1e83a2d0262d6c2e2c2745f5ea198153fba80718aabac2955c691e6cb9bd5f4b5 shortuuid-0.5.0.tar.gz"