aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/i3blocks/APKBUILD4
-rw-r--r--testing/i3blocks/fix-makefile.patch15
2 files changed, 18 insertions, 1 deletions
diff --git a/testing/i3blocks/APKBUILD b/testing/i3blocks/APKBUILD
index 7af6e2aef29..ea5dc4408a0 100644
--- a/testing/i3blocks/APKBUILD
+++ b/testing/i3blocks/APKBUILD
@@ -11,6 +11,7 @@ options="!check" # no test suite
makedepends="ronn autoconf automake bash-completion"
subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/vivien/i3blocks/archive/$pkgver.tar.gz
+ fix-makefile.patch
"
prepare() {
@@ -40,4 +41,5 @@ bashcomp() {
mkdir -p "$subpkgdir"/usr/share
mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
}
-sha512sums="759829d59f94070251378d437891c2df05715fbd0b734c34dd41767d61957f301c6125b0058668295b8eeac29038fae6b2e8c194f903398ee736662213d1d534 i3blocks-1.5.tar.gz"
+sha512sums="759829d59f94070251378d437891c2df05715fbd0b734c34dd41767d61957f301c6125b0058668295b8eeac29038fae6b2e8c194f903398ee736662213d1d534 i3blocks-1.5.tar.gz
+b54fb4b9f2a08a1bfafb7ebcf36c87c850d795af2c6f4509bcfa0853340f96bf13662445e24033a94c6e13b9e0b8a7ab6a52a914b99ee8196e0d2275eaf9b5d1 fix-makefile.patch"
diff --git a/testing/i3blocks/fix-makefile.patch b/testing/i3blocks/fix-makefile.patch
new file mode 100644
index 00000000000..22c41a1a304
--- /dev/null
+++ b/testing/i3blocks/fix-makefile.patch
@@ -0,0 +1,15 @@
+diff --git a/Makefile.am b/Makefile.am
+index d755a2b..f8a598e 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -34,9 +34,6 @@ if ENABLE_BASH_COMPLETION
+ bashcompletiondir = $(BASH_COMPLETION_DIR)
+ bashcompletion_DATA = bash-completion
+
+-install-data-local:
+- ( cd '$(DESTDIR)$(BASH_COMPLETION_DIR)' && mv bash-completion i3blocks )
+-
+ uninstall-local:
+ ( cd '$(DESTDIR)$(BASH_COMPLETION_DIR)' && rm -rf i3blocks )
+ endif
+