aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/postgresql-timescaledb/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/testing/postgresql-timescaledb/APKBUILD b/testing/postgresql-timescaledb/APKBUILD
index 57cfd3a7303..24c556dce03 100644
--- a/testing/postgresql-timescaledb/APKBUILD
+++ b/testing/postgresql-timescaledb/APKBUILD
@@ -12,13 +12,22 @@ provides="timescaledb=$pkgver-r$pkgrel" # for backward compatibility
makedepends="postgresql-dev cmake bash"
source="https://github.com/timescale/timescaledb/archive/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_projname-$pkgver"
+options="!check" # FIXME: see comment on REGRESS_CHECKS=OFF below
+
+export USE_PGXS=1
build() {
+ # CFLAGS - performance is more important than binary size in this case
# REGRESS_CHECKS=OFF - disable regress test
- # regress need https://github.com/timescale/timescaledb/blob/master/test/pg_isolation_regress.sh
- # which need to compile pg - https://github.com/timescale/timescaledb/issues/1655#issuecomment-578683986
- BUILD_FORCE_REMOVE=true ./bootstrap -DREGRESS_CHECKS=OFF
- make -C build USE-PGXS=1
+ # regress need https://github.com/timescale/timescaledb/blob/master/test/pg_isolation_regress.sh
+ # which need to compile pg - https://github.com/timescale/timescaledb/issues/1655#issuecomment-578683986
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS="${CFLAGS/-Os/-O2} -DNDEBUG" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DREGRESS_CHECKS=OFF
+ make -C build
}
check() {
@@ -26,7 +35,7 @@ check() {
}
package() {
- make -C build USE_PGXS=1 DESTDIR="$pkgdir" install
+ make -C build install DESTDIR="$pkgdir"
}
sha512sums="53fddb9fe4c4ab51ebc020e90eea5b032b41259d3bd45e8a03a86451acd7f8864b5a6ecba1b82b7c78e230f62cfddf1da75ff27e6629ad5fe8178839ac411ce4 postgresql-timescaledb-2.1.0.tar.gz"