aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/boost-coroutine/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/boost-coroutine/APKBUILD')
-rw-r--r--unmaintained/boost-coroutine/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/boost-coroutine/APKBUILD b/unmaintained/boost-coroutine/APKBUILD
new file mode 100644
index 00000000000..60a0ee3de90
--- /dev/null
+++ b/unmaintained/boost-coroutine/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=boost-coroutine
+pkgver=0.0.1
+pkgrel=4
+pkgdesc="coroutine library for boost"
+url="http://www.crystalclearsoftware.com/soc/coroutine/"
+#arch="noarch"
+license="custom:boost"
+depends=
+depends_dev="boost-dev pth-dev"
+install=""
+source="boost-coroutine-2009-12-01.tar.gz::http://www.boostpro.com/vault/index.php?action=downloadfile&filename=boost-coroutine-2009-12-01.tar.gz&directory=Concurrent%20Programming
+ boost-coroutine-pth.patch"
+
+_builddir="${srcdir}/boost-coroutine"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/include
+ cp -r "$_builddir"/boost "$pkgdir"/usr/include/boost
+}
+
+md5sums="d74b6aa80aeb09eb08d644710c7849c4 boost-coroutine-2009-12-01.tar.gz
+53d3c4752668f0332dc31bd2341db609 boost-coroutine-pth.patch"
+sha256sums="0211b773c7528cf3487087a08d35454332f3e63f58c926e43c5933b7783b6a70 boost-coroutine-2009-12-01.tar.gz
+b9c7951d47ec200366a17dcf6da634370bc59543d17ef16eb82f2a97d7bb732e boost-coroutine-pth.patch"
+sha512sums="acb8644fd3e960fb316ba3436af9bc2e2da91536afd182577358ac061348d7c0a29420308ece188dbc7a58d119dc19c09e7b486f66f1f8f1d6e23a489c183dfe boost-coroutine-2009-12-01.tar.gz
+5229bd3f8f89fc1a07356277d0f1319a964b6bc27ea24228f942a67c8cfd3eb038c35284d8c5b58b68163410fa443f60188b8c2fbaad340c3927fd206cdad258 boost-coroutine-pth.patch"