aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libc++/no-libunwind-sources.patch
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/libc++/no-libunwind-sources.patch')
-rw-r--r--unmaintained/libc++/no-libunwind-sources.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/libc++/no-libunwind-sources.patch b/unmaintained/libc++/no-libunwind-sources.patch
new file mode 100644
index 00000000000..d9c31051b54
--- /dev/null
+++ b/unmaintained/libc++/no-libunwind-sources.patch
@@ -0,0 +1,44 @@
+Shiz created this revision.
+Herald added a subscriber: mgorny.
+
+As per r241993, libunwind_ext.h is not used anymore, and thus only the public libunwind includes are needed.
+This eases distro packaging efforts and removes an unneeded requirement for out-of-tree building.
+
+
+Repository:
+ rL LLVM
+
+https://reviews.llvm.org/D33178
+
+Files:
+ libcxxabi/CMakeLists.txt
+
+
+Index: libcxxabi/CMakeLists.txt
+===================================================================
+--- a/libcxxabi/CMakeLists.txt
++++ b/libcxxabi/CMakeLists.txt
+@@ -459,23 +459,7 @@
+ NO_DEFAULT_PATH
+ )
+
+- find_path(
+- LIBCXXABI_LIBUNWIND_SOURCES
+- libunwind_ext.h
+- PATHS ${LIBCXXABI_LIBUNWIND_PATH}/src/
+- ${LIBCXXABI_LIBUNWIND_INCLUDES}/../src/
+- ${LLVM_MAIN_SRC_DIR}/projects/libunwind/src/
+- ${LLVM_MAIN_SRC_DIR}/runtimes/libunwind/src/
+- NO_DEFAULT_PATH
+- )
+-
+- if (LIBCXXABI_LIBUNWIND_SOURCES STREQUAL "LIBCXXABI_LIBUNWIND_SOURCES-NOTFOUND")
+- message(WARNING "LIBCXXABI_LIBUNWIND_SOURCES was not specified and couldn't be infered.")
+- set(LIBCXXABI_LIBUNWIND_SOURCES "")
+- endif()
+-
+ include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
+- include_directories("${LIBCXXABI_LIBUNWIND_SOURCES}")
+ endif()
+
+ # Add source code. This also contains all of the logic for deciding linker flags