aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ocaml-topkg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/ocaml-topkg/APKBUILD')
-rw-r--r--unmaintained/ocaml-topkg/APKBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/unmaintained/ocaml-topkg/APKBUILD b/unmaintained/ocaml-topkg/APKBUILD
deleted file mode 100644
index 9bc6869d1dd..00000000000
--- a/unmaintained/ocaml-topkg/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer:
-# FIXME: run tests!
-pkgname=ocaml-topkg
-_pkgname=topkg
-pkgver=0.9.1
-pkgrel=2
-pkgdesc="The transitory OCaml software packager"
-url="http://erratique.ch/software/topkg"
-arch="all !x86 !armhf !armv7 !s390x !mips !mips64" # limited by ocaml aport
-license="ISC"
-depends="ocaml-result ocaml-runtime"
-depends_dev="$pkgname=$pkgver-r$pkgrel"
-makedepends="ocaml ocaml-compiler-libs ocaml-findlib ocaml-result-dev ocamlbuild opam"
-subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/dbuenzli/$_pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- ocaml pkg/pkg.ml build
-}
-
-package() {
- cd "$builddir"
-
- opam-installer -i \
- --prefix="$pkgdir/usr" \
- --libdir="$pkgdir/usr/lib/ocaml" \
- --docdir="$builddir/.omit" \
- $_pkgname.install
-
- # Remove annotation files.
- rm -Rf "$pkgdir"/usr/lib/ocaml/$_pkgname/*.cmt*
-}
-
-dev() {
- local sitelib="usr/lib/ocaml/$_pkgname"
- default_dev
-
- cd "$pkgdir"/$sitelib
-
- mkdir -p "$subpkgdir"/$sitelib
- mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
-}
-
-sha512sums="19773eb764b53a6e5110c44d7942d2557d6c8502a3037b57f7737efc08f4cc374845b431fdb1465207693d15a4b072aea3db97f8e60e069e3d24ae150e8c5c8f ocaml-topkg-0.9.1.tar.gz"