aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-class-gomor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/perl-class-gomor/APKBUILD')
-rw-r--r--unmaintained/perl-class-gomor/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/unmaintained/perl-class-gomor/APKBUILD b/unmaintained/perl-class-gomor/APKBUILD
new file mode 100644
index 00000000000..db6d2452ffc
--- /dev/null
+++ b/unmaintained/perl-class-gomor/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=perl-class-gomor
+_realname=Class-Gomor
+pkgver=1.02
+pkgrel=0
+pkgdesc="Another class and object builder"
+url="http://search.cpan.org/~gomor/Class-Gomor-1.02/"
+arch="noarch"
+license="PerlArtistic"
+depends="perl"
+depends_dev=""
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GO/GOMOR/$_realname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="287c3b3be72fcb4a4089fe232b8b1002 Class-Gomor-1.02.tar.gz"