aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-time-local/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/perl-time-local/APKBUILD')
-rw-r--r--unmaintained/perl-time-local/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/unmaintained/perl-time-local/APKBUILD b/unmaintained/perl-time-local/APKBUILD
new file mode 100644
index 00000000000..62ae9966d7f
--- /dev/null
+++ b/unmaintained/perl-time-local/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-time-local
+_pkgreal=Time-Local
+pkgver=1.2000
+pkgrel=0
+pkgdesc="unknown"
+url="http://search.cpan.org/dist/Time-Local/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="dc9c362e980830d62b1e9653ca4f27fd Time-Local-1.2000.tar.gz"