aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-twisted-conch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/py-twisted-conch/APKBUILD')
-rw-r--r--unmaintained/py-twisted-conch/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/unmaintained/py-twisted-conch/APKBUILD b/unmaintained/py-twisted-conch/APKBUILD
new file mode 100644
index 00000000000..997c9fa6433
--- /dev/null
+++ b/unmaintained/py-twisted-conch/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-twisted-conch
+pkgver=15.1.0
+pkgrel=0
+pkgdesc="SSH and SFTP protocol implementation together with clients and servers"
+url="http://twistedmatrix.com/trac/wiki/TwistedConch"
+arch="noarch"
+license="MIT"
+depends="py-twisted py-crypto py-asn1"
+makedepends="python-dev"
+source="http://twistedmatrix.com/Releases/Conch/${pkgver%.*}/TwistedConch-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/TwistedConch-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="73c9c432b614655d6dcf5db4c00e632f TwistedConch-15.1.0.tar.bz2"
+sha256sums="51dc4d3ab3f13e64a196046e3d722689f87c586f3ebe42e287c2063fdd48bb4c TwistedConch-15.1.0.tar.bz2"
+sha512sums="912d9a288fcc6bb3e8babee75325ea7a384e364d227f0629bbb5af8c813cff75dbeb38755d2f0eb5bd5ac243c45c4ed5f1c9e01bf0d693b027adeeef59ebd691 TwistedConch-15.1.0.tar.bz2"