summaryrefslogtreecommitdiffstats
path: root/x11/libxau/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libxau/APKBUILD')
-rw-r--r--x11/libxau/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11/libxau/APKBUILD b/x11/libxau/APKBUILD
new file mode 100644
index 00000000000..f5295bceaf5
--- /dev/null
+++ b/x11/libxau/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxau
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="X11 authorisation library"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends="uclibc"
+makedepends="pkgconfig xproto"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://xorg.freedesktop.org/releases/individual/lib/libXau-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/libXau-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 -d "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING || return 1
+}
+md5sums="0f2b88d857e0a3f5898e4759c541af46 libXau-1.0.4.tar.bz2"