summaryrefslogtreecommitdiffstats
path: root/x11/ristretto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'x11/ristretto/APKBUILD')
-rw-r--r--x11/ristretto/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11/ristretto/APKBUILD b/x11/ristretto/APKBUILD
new file mode 100644
index 00000000000..5c651efb771
--- /dev/null
+++ b/x11/ristretto/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ristretto
+pkgver=0.0.22
+pkgrel=0
+pkgdesc="Ristretto is a image viewer for Xfce"
+url="http://goodies.xfce.org/projects/applications/ristretto"
+license="GPL-2"
+depends="desktop-file-utils hicolor-icon-theme"
+makedepends="pkgconfig libxfcegui4-dev dbus-glib-dev libexif-dev intltool
+ gettext-dev libiconv-dev thunar-dev"
+install="ristretto.post-install ristretto.post-upgrade ristretto.post-deinstall"
+source="http://goodies.xfce.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ $install"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="978ae19472c5a0b7d4b6622a68234a67 ristretto-0.0.22.tar.gz
+9ba052c0be9f3e3ae52ef7d45083efa3 ristretto.post-install
+9ba052c0be9f3e3ae52ef7d45083efa3 ristretto.post-upgrade
+9ba052c0be9f3e3ae52ef7d45083efa3 ristretto.post-deinstall"