aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* community/composer: upgrade to 1.8.0Andy Postnikov2018-12-051-2/+2
|
* community/php7-pecl-redis: update checksumsAndy Postnikov2018-12-051-2/+2
|
* main/lua-sqlite: upgrade to 0.9.5Carlo Landmeter2018-12-051-6/+4
|
* community/caddy: upgrade to 0.11.1Carlo Landmeter2018-12-051-12/+17
|
* testing/iucode-tool: new aportNatanael Copa2018-12-051-0/+37
| | | | | manipulate microcode update collections for Intel i686 and X86-64 https://gitlab.com/iucode-tool/iucode-tool
* main/nano: Upgrade to 3.2Taner Tas2018-12-051-2/+2
|
* testing/shairport-sync: Fix abuild warningsHenrik Nilsson2018-12-051-2/+3
| | | | | Skip test's as they do not exist. Added openrc subpackage.
* main/nodejs: upgrade to 10.14.1Tim Brust2018-12-051-2/+2
|
* community/fzf: disable on s390xNatanael Copa2018-12-051-1/+1
| | | | | build fails with: Makefile:56: *** "Build on s390x is not supported, yet.". Stop.
* main/wayland: upgrade to 1.16.0emersion2018-12-051-2/+2
|
* main/putty: fix ppc64le bld break by disabling WerrorMike Sullivan2018-12-052-3/+16
|
* main/gstreamer0.10: fix ppc64le bld break by adding perl makedependsMike Sullivan2018-12-051-2/+2
|
* main/glibmm: fix ppc64le build break of doc pkg by adding perl makedependMike Sullivan2018-12-051-2/+2
|
* main/eventlog: fix bld break by updating download source locationMike Sullivan2018-12-051-2/+2
|
* main/debian-archive-keyring: bld break pkg no longer available. Upgrade to ↵Mike Sullivan2018-12-051-2/+2
| | | | 2018.1
* main/checkbashisms: bld break because pkg missing. Upgrade to latest versionMike Sullivan2018-12-051-2/+2
|
* main/atkmm: fix ppc64le bld break by including perl to makedependsMike Sullivan2018-12-051-2/+2
|
* main/apache-mod-fcgid: update source download location to fix bld breakMike Sullivan2018-12-051-6/+2
|
* main/py-romam: remove md5sums and sha512sums and force rebuildMike Sullivan2018-12-051-3/+1
|
* main/perl: security upgrade to 5.26.3Natanael Copa2018-12-041-3/+8
| | | | | | CVE-2018-18311, CVE-2018-18312, CVE-2018-18313, CVE-2018-18314 fixes #9727
* main/libao: security fix for CVE-2017-11548Natanael Copa2018-12-042-3/+187
| | | | fixes #9208
* main/lighttpd: upgrade to 1.4.52Andy Postnikov2018-12-041-3/+3
|
* main/lua5.3: fix linenoise patchNatanael Copa2018-12-042-9/+9
| | | | ref #9644
* community/py-mysqlclient: set maintainerCarlo Landmeter2018-12-041-1/+1
|
* community/py-mysqlclient: moved from testingCarlo Landmeter2018-12-041-0/+0
|
* main/py-docutils: make sure that subpackages' deps are built firstNatanael Copa2018-12-041-2/+4
| | | | | We need to make sure that the py-pillow and py-roman packages are built before py-docutils. Do so by adding those to makedepends.
* main/perl-io-socket-ssl: upgrade to 2.060Natanael Copa2018-12-041-3/+3
|
* main/perl-net-ssleay: add patches from fedoraNatanael Copa2018-12-043-2/+301
| | | | those fixes perl-io-socket-ssl test suite
* testing/wireguard-virt: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* testing/wireguard-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* testing/ipt-netflow-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* main/zfs-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* main/xtables-addons-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* main/spl-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-2/+2
|
* main/drbd9-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* main/devicemaster-linux-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* main/dahdi-linux-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* community/virtualbox-guest-modules-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* community/aws-ena-driver-vanilla: rebuild against kernel 4.14.85-r0Natanael Copa2018-12-041-1/+1
|
* main/linux-vanilla: upgrade to 4.14.85Natanael Copa2018-12-041-2/+2
|
* testing/py-mysqlclient: new aportCarlo Landmeter2018-12-031-0/+47
|
* main/qemu: upgrade to 3.0.0Natanael Copa2018-12-033-75/+8
|
* main/aria2: add subpackage -daemon for running aria2 as a daemonJakub Jirutka2018-12-016-4/+149
|
* main/wget: upgrade to 1.20Andy Postnikov2018-12-011-3/+3
|
* community/openjdk7: modernizeNatanael Copa2018-11-301-17/+15
| | | | use bash for icedtea-bootstrap
* community/java-gcj-compat: resurrect. needed by openjdk7Natanael Copa2018-11-301-0/+81
| | | | adjust for gcc6
* community/gcc6: move from testingNatanael Copa2018-11-3048-0/+0
| | | | needed too bootstrap openjdk7
* main/samba: Upgrade to 4.8.7Linux User2018-11-301-2/+7
| | | | | | | | | | | | Fix: CVE-2018-14629 CVE-2018-16841 CVE-2018-16851 CVE-2018-16853 https://www.samba.org/samba/history/samba-4.8.7.html fixes #9706
* community/ilmbase: fix build (bashisms)info@mobile-stream.com2018-11-301-1/+2
| | | | | | | | | | | On edge (x86_64, mipsel) build fails: ./configure: line 17377: syntax error: unexpected "(" (expecting "fi") checkbashisms reports multiple problems in ./configure so just run it with /bin/bash (especially since makedepends requires bash). Note neither 2.2.1 (tried) nor 2.3.0 (according to the source code) change anything regarding this matter.
* main/nodejs: fix build on mips{el} (-latomic), disable on mips64*info@mobile-stream.com2018-11-302-3/+33
| | | | | | | | | | | | 1) Add the usual -latomic for pre-R6 MIPS32. 2) Alpine mips64* definitions assume MIPS III but nodejs wants MIPS32 at least and can actually generate instructions missing in MIPS III, e.g. movn/movz. There is also some support for Loongson 2 (which is a MIPS III CPU) however it apparently always targets hard-float O32 ABI so be safe and disable build on mips64* completely. Keep pkgrel intact since no previously built mips* apks exist and changes are strictly mips-specific.