aboutsummaryrefslogtreecommitdiffstats
path: root/community/docker
Commit message (Collapse)AuthorAgeFilesLines
* community/docker: upgrade to 18.09.8Jake Buchholz2019-07-201-10/+13
| | | | | | | https://github.com/docker/docker-ce/releases/tag/v18.09.8 * Fix CVE-2019-13509 in DebugRequestMiddleware: unconditionally scrub data field. Also, compile docker engine with seccomp.
* community/docker: security upgrade to 18.09.7 (CVE-2018-15664)Natanael Copa2019-07-021-6/+10
|
* community/docker: remove old tini patchJake Buchholz2019-01-111-78/+0
|
* community/docker: update to 18.09.1Jake Buchholz2019-01-111-6/+6
| | | | | * update to 18.09.1 - see https://github.com/docker/docker-ce/releases/tag/v18.09.1 for release notes. * use the whole commit hash for versioning.
* community/docker: upgrade to 18.09.0, etc.Jake Buchholz2019-01-101-82/+31
| | | | | | | * update docker to 18.09.0 * containerd and rund are now built separately * add dependency on tini-static, no need to build it here * use new go-md2man package to process manpages
* community/docker: upgrade to 18.06.1, added openrc sub-packageBernhard J. M. Gruen2018-09-031-13/+14
| | | | | | | This change to APKBUILD for runc also fixes a warning that gets logged every 30 seconds while running dockerd: failed to retrieve docker-runc version: unknown output format: runc version spec: 1.0.0\n Reason: the way it was built before was partially wrong
* community/docker: upgrade to 18.03.1Matthieu Monnier2018-05-081-9/+9
|
* community/docker: fix runscript for openrc 0.35 - need cgroupsJakub Jirutka2018-04-232-3/+3
| | | | | The cgroups mounting logic has been moved from the sysfs service to the cgroups service in OpenRC 0.35.
* community/docker: upgrade to 18.03.0Matthieu Monnier2018-04-051-11/+11
|
* community/docker: upgrade to 18.02.0 (edge release)Bernhard J. M. Gruen2018-03-091-21/+14
|
* community/docker: add install_if for vim subpackagesSören Tempel2018-03-071-2/+3
| | | | | | Other packages providing a vim subpackage (e.g. main/mercurial) also add an install_if rule for their vim subpackage. So for the sake of consistency do it here as well.
* community/docker: update to 17.12.1Bernhard J. M. Gruen2018-03-021-2/+2
|
* community/docker: enable on s390xNatanael Copa2018-02-131-1/+1
|
* community/docker: upgrade to 17.12.0Kevin Daudt2018-02-071-10/+8
|
* [various]: unify names of licenses according to SPDXJakub Jirutka2017-12-301-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This commit updates $license variable in all APKBUILDs to comply with short names specified by SPDX version 3.0 [1] where possible. It was done using find-and-replace method on substrings inside $license variables. Only license names were updated, not "expressions" specifying relation between the licenses (e.g. "X and Y", "X or Y", "X and (Y or Z)") or exceptions (e.g. "X with exceptions"). Many licenses have a version or multiple variants, e.g. MPL-2.0, BSD-2-Clause, BSD-3-Clause. However, $license in many aports do not contain license version or variant. Since there's no way how to infer this information just from abuild, it were left without the variant suffix or version, i.e. non SPDX compliant. GNU licenses (AGPL, GFDL, GPL, LGPL) are especially complicated. They exist in two variants: -only (formerly e.g. GPL-2.0) and -or-later (formerly e.g. GPL-2.0+). We did not systematically noted distinguish between these variants, so GPL-2.0, GPL2, GPLv2 etc. may mean GPL-2.0-only or GPL-2.0-or-later. Thus GNU licenses without "+" (e.g. GPL2+) were left without the variant suffix, i.e. non SPDX compliant. Note: This commit just fixes format of the license names, no verification has been done if the specified license information is actually correct! [1]: https://spdx.org/licenses/
* community/docker: fix checksumsNatanael Copa2017-11-211-7/+10
| | | | | we cannot expect that git master of cobra and go-md2man will remain unmodified. Use the last release tag.
* community/docker: upgrade to 17.10.0TBK2017-11-211-46/+51
|
* community/docker: update build to 17.07.0Joe Groocock2017-09-281-54/+75
|
* community/[various]: fix trailing whitespacetmpfile2017-07-101-1/+1
|
* community/docker: enable on ppc64leNatanael Copa2017-05-161-1/+1
|
* community/docker: upgrade to 17.05.0Matthieu Monnier2017-05-161-6/+6
|
* community/[various]: no support for s390x yetTuan M. Hoang2017-05-101-1/+1
| | | | | | | | | | | | | py-opencl, R: missing dependencies community/{OpenBLAS,py-numpy} openspecfun: missing dependency community/openlibm llvm-libunwind: no support yet drawterm: no support yet caddy: https://github.com/caddyserver/buildworker/blob/e040f51c04552896ffe33a926cd76babed902b48/buildenv.go#L239 docker: disable for now. Currently we still cannot boot Alpine s390x natively yet, most usage are running inside containers. Thus it is not likely we need Docker on s390x for now.
* community/docker: fix tarball source urlNatanael Copa2017-05-041-5/+5
| | | | upstream github project changed name to moby
* community/docker: Disable build on ppc64leBreno Leitao2017-04-101-1/+1
| | | | | | Disabling the build on ppc64le because 'go' is still not available at this moment. This commit should be reverted once we have go built on ppc64le.
* community/docker: upgrade to 17.04.0Matthieu Monnier2017-04-071-14/+14
|
* community/docker: ulimit -u to -pHenrik Riomar2017-04-062-2/+15
| | | | | | | | | | | | | | | | | There is no -u flag to ulimit provided by Busybox ash, change to -p in docker.init bash ulimit: -n The maximum number of open file descriptors -u The maximum number of processes available to a single user ash ulimit (from Busybox): { RLIMIT_NOFILE, 0, 'n', "file descriptors" }, { RLIMIT_NPROC, 0, 'p', "processes" }, References: https://github.com/docker/docker/commit/428d7337e808ec5f4dba1b0aceda002f295cc320 https://github.com/docker/docker/commit/8db61095a3d0bcb0733580734ba5d54bc27a614d
* community/docker: upgrade to 17.03.1 and add ca-certificates dependencyMatthieu Monnier2017-03-301-8/+8
|
* community/docker: Fixing some packaging issues, adding docker-doc subpackage.Gennady Feldman2017-03-302-5/+111
| | | | | | | * Needed to tweak tini to return not just version but also commit. This is needed so docker doesn't complain it can't get version. * Added docker-doc man pages (sub package) * Upgrade to v17.03.1-ce
* community/docker: Fixing APKBUILD, adding tini.Gennady Feldman2017-03-241-18/+40
| | | | | | | | * Trying to fix broken APKBUILD. (Wasn't catching package errors) * Adding tini (docker-init binary) * Added fish completion sub-package * Re-enabled aufs and devicemapper
* community/docker: upgrade to 1.13.1Ivan Tham2017-02-231-12/+2
|
* community/docker: upgrade to 1.13.0Natanael Copa2017-01-202-25/+44
|
* community/docker: upgrade to 1.12.6Natanael Copa2017-01-111-4/+4
|
* community/docker: upgrade to 1.12.5Natanael Copa2017-01-091-4/+4
|
* community/[various]: dont set arch in split functionTimo Teräs2016-11-021-6/+3
|
* community/docker: upgrade to 1.12.3Natanael Copa2016-10-281-5/+5
|
* community/docker: upgrade to 1.12.2Carlo Landmeter2016-10-121-4/+4
|
* community/docker: make docker service depend on sysfsNatanael Copa2016-09-142-19/+24
| | | | ref #6038
* community/docker: upgrade to 1.12.1Natanael Copa2016-08-251-5/+4
|
* community/docker: upgrade to 1.12.0Natanael Copa2016-07-293-103/+29
|
* community/docker: upgrade to 1.11.2Natanael Copa2016-06-161-4/+4
|
* community/docker: upgrade to 1.11.1Natanael Copa2016-04-281-13/+13
|
* community/[various]: bump pkgrel for pre-install fixesPrzemyslaw Pawelczyk2016-04-251-1/+1
|
* Improve consistency of scripts using adduser/addgroup.Przemyslaw Pawelczyk2016-04-251-3/+2
| | | | | | | | | | | | Following rules have been applied: - script starts with shebang !#/bin/sh followed by blank line, - script ends with exit 0 prepended by blank line, - only stderr of adduser, addgroup or passwd is redirected to /dev/null, - getent passwd/group instances has been removed, - manual checking of file and group existence has been removed, - `|| true` instances has been removed. Comments and line wrapping have been preserved.
* community/docker: add needed binariesNatanael Copa2016-04-194-19/+156
| | | | | docker 1.11 needs runc, containerd and containerd-shim. We bundle those simliar to how the precompiled official docker binary distribution does.
* community/docker: new upstream version 1.11.0Christian Kampka2016-04-161-4/+4
|
* community/docker: new upstream version 1.10.3Christian Kampka2016-03-201-4/+4
|
* community/docker: upgrade to 1.10.2Natanael Copa2016-02-241-4/+4
|
* community/docker: upgrade to 1.10.1Natanael Copa2016-02-121-4/+4
|
* community/docker: upgrade to 1.10.0Natanael Copa2016-02-051-5/+5
|
* community/docker: bump pkgrelBartłomiej Piotrowski2015-12-011-1/+1
|