aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud-client
Commit message (Collapse)AuthorAgeFilesLines
* community/nextcloud-client: disable on mipsAriadne Conill17 hours1-2/+2
|
* community/nextcloud-client: upgrade to 2.6.4TBK2020-03-201-3/+3
|
* community/*: make CMake and meson respect our C{,PP,XX}FLAGSRasmus Thomsen2020-02-211-2/+2
| | | | See: https://lists.alpinelinux.org/~alpine/devel/%3C2896c13070c508a49cbaa72c8fb7f34ea947358b.camel%40cogitri.dev%3E
* community/nextcloud-client: disable built-in update checkBart Ribbers2020-02-182-3/+9
| | | | | We don't want users to receive a notification to update while it's not available in our repositories yet
* community/nextcloud-client: upgrade to 2.6.3Rasmus Thomsen2020-02-171-2/+2
|
* community/*: disable on armhf where depending on extra-cmake-modulesBart Ribbers2020-01-291-1/+3
|
* community/nextcloud-client: upgrade to 2.6.2Leonardo Arena2019-12-271-2/+2
|
* community/nextcloud-client: upgrade to 2.6.1Bart Ribbers2019-11-171-3/+3
|
* community/nextcloud-client: disable on ppc64leKevin Daudt2019-10-201-1/+1
| | | | qt5-webengine is missing.
* community/nextcloud-client: disable on s390x due to qt5-qtwebengineRasmus Thomsen2019-10-201-1/+1
|
* community/nextcloud-client: use QtWebEngine again now that it worksRasmus Thomsen2019-10-202-318/+4
|
* community/nextcloud-client: add -dolphin subpackageBart Ribbers2019-10-131-3/+14
|
* community/nextcloud-client: upgrade to 2.6.0Rasmus Thomsen2019-10-072-77/+187
|
* community/nextcloud-client: re-enable all architectures, modernizeBart Ribbers2019-06-242-9/+214
| | | | Also remove qt5-qtwebengine as it's broken right now
* community/nextcloud-client: upgrade to 2.5.2Leonardo Arena2019-05-171-3/+3
|
* community/nextcloud-client: disable on ppc64le due to qt5-webengineMike Sullivan2018-12-281-1/+1
|
* community/nextcloud-client: disable on s390x due to qt5-webengineCarlo Landmeter2018-12-191-1/+1
|
* community/nextcloud-client: don't build for x86Leonardo Arena2018-12-131-2/+2
| | | | qt5-qtwebengine not available on x86
* community/nextcloud-client: upgrade to 2.5.1Leonardo Arena2018-12-131-14/+9
|
* community/nextcloud-client: fix building with Nextcloud themeLeonardo Arena2018-05-311-2/+2
|
* [various]: unify names of licenses according to SPDXJakub Jirutka2017-12-301-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This commit updates $license variable in all APKBUILDs to comply with short names specified by SPDX version 3.0 [1] where possible. It was done using find-and-replace method on substrings inside $license variables. Only license names were updated, not "expressions" specifying relation between the licenses (e.g. "X and Y", "X or Y", "X and (Y or Z)") or exceptions (e.g. "X with exceptions"). Many licenses have a version or multiple variants, e.g. MPL-2.0, BSD-2-Clause, BSD-3-Clause. However, $license in many aports do not contain license version or variant. Since there's no way how to infer this information just from abuild, it were left without the variant suffix or version, i.e. non SPDX compliant. GNU licenses (AGPL, GFDL, GPL, LGPL) are especially complicated. They exist in two variants: -only (formerly e.g. GPL-2.0) and -or-later (formerly e.g. GPL-2.0+). We did not systematically noted distinguish between these variants, so GPL-2.0, GPL2, GPLv2 etc. may mean GPL-2.0-only or GPL-2.0-or-later. Thus GNU licenses without "+" (e.g. GPL2+) were left without the variant suffix, i.e. non SPDX compliant. Note: This commit just fixes format of the license names, no verification has been done if the specified license information is actually correct! [1]: https://spdx.org/licenses/
* community/nextcloud-client: upgrade to 2.3.3, modernize APKBUILDLeonardo Arena2017-12-291-15/+7
|
* community/nextcloud-client: update checksumRoberto Oliveira2017-11-171-2/+2
|
* community/nextcloud-client: upgrade to 2.3.2Leonardo Arena2017-09-021-4/+4
|
* community/nextcloud-client: rebuild against new qt5-qtkeychainLeonardo Arena2017-03-271-1/+1
|
* community/nextcloud-client: moved from testingLeonardo Arena2017-03-271-0/+44